aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-battery-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:46:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:46:49 +0000
commit9fc8f267f405bda41b14ea8d0020c5e5e02938ae (patch)
tree02c4c63efcb44801c23dfc8944f6ce99093353a1 /sysutils/xfce4-battery-plugin
parentd9106b3dbac84a14015c7d5df3c3a4fc7bcd349c (diff)
downloadports-9fc8f267f405bda41b14ea8d0020c5e5e02938ae.tar.gz
ports-9fc8f267f405bda41b14ea8d0020c5e5e02938ae.zip
- Update to 1.0.0
PR: 153661 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=271123
Diffstat (limited to 'sysutils/xfce4-battery-plugin')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile27
-rw-r--r--sysutils/xfce4-battery-plugin/distinfo5
-rw-r--r--sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c59
-rw-r--r--sysutils/xfce4-battery-plugin/pkg-plist84
4 files changed, 76 insertions, 99 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 437475bf31ca..267c428a3fcf 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfce4-battery-plugin
-PORTVERSION= 0.5.1
-PORTREVISION= 9
+PORTVERSION= 1.0.0
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -18,11 +17,27 @@ COMMENT= Battery monitor panel plugin for XFce4
ONLY_FOR_ARCHS= i386 amd64
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel
+USE_GNOME= gnomehack gtk20 glib20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+INSTALLS_ICONS= yes
+
+CONFIGURE_ARGS= --disable-debug
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/xfce4-battery-plugin/distinfo b/sysutils/xfce4-battery-plugin/distinfo
index c713ad6ee835..e9435616d898 100644
--- a/sysutils/xfce4-battery-plugin/distinfo
+++ b/sysutils/xfce4-battery-plugin/distinfo
@@ -1,3 +1,2 @@
-MD5 (xfce4/xfce4-battery-plugin-0.5.1.tar.bz2) = d8a666d85bb3c1dd007b547de4dd7037
-SHA256 (xfce4/xfce4-battery-plugin-0.5.1.tar.bz2) = 6b90a37d8f01d2f042679a3f3f92f08dee96510096115f52fb9210ef4cad7c61
-SIZE (xfce4/xfce4-battery-plugin-0.5.1.tar.bz2) = 227940
+SHA256 (xfce4/xfce4-battery-plugin-1.0.0.tar.bz2) = c28bb580e6b932c017b5bc6b2e75de8c3557e08d9606c7a70134aa035f8a121f
+SIZE (xfce4/xfce4-battery-plugin-1.0.0.tar.bz2) = 358338
diff --git a/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c b/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c
deleted file mode 100644
index e3b9a4b423ee..000000000000
--- a/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c
+++ /dev/null
@@ -1,59 +0,0 @@
---- panel-plugin/battery.c.orig 2008-09-04 17:53:40.000000000 -0300
-+++ panel-plugin/battery.c 2008-09-10 21:53:56.000000000 -0300
-@@ -26,7 +26,9 @@
- #endif
-
- #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
-+#if defined(__i386___)
- #include <machine/apm_bios.h>
-+#endif
- #elif __OpenBSD__
- #include <sys/param.h>
- #include <machine/apmvar.h>
-@@ -163,7 +165,9 @@
- except that is does not work on FreeBSD
-
- */
-+#ifdef APMDEVICE
- struct apm_info apm;
-+#endif
- int fd;
-
- /* First check to see if ACPI is available */
-@@ -310,7 +314,9 @@
- acline = apm.ac_state ? TRUE : FALSE;
-
- #else
-- struct apm_info apm;
-+#ifdef APMDEVICE
-+struct apm_info apm;
-+#endif
- DBG ("Updating battery status...");
-
- if(battmon->method == BM_BROKEN) {
-@@ -382,6 +388,7 @@
- rate = last_rate;
- }
-
-+#ifdef __linux__
- charge = (((float)ccapacity)/((float)lcapacity))*100;
-
- if ( last_acline )
-@@ -394,6 +401,17 @@
-
- last_acline = acline;
-
-+#elif __FreeBSD__
-+ charge = acpistate->percentage;
-+
-+ if ( last_acline)
-+ time_remaining = acpistate->rtime;
-+ else
-+ time_remaining = acpistate->rtime;
-+
-+ if ( time_remaining < 0 )
-+ time_remaining = 0;
-+#endif
- }
- #ifdef __linux__
- else {
diff --git a/sysutils/xfce4-battery-plugin/pkg-plist b/sysutils/xfce4-battery-plugin/pkg-plist
index a64ffead1d69..a8e68973c4e0 100644
--- a/sysutils/xfce4-battery-plugin/pkg-plist
+++ b/sysutils/xfce4-battery-plugin/pkg-plist
@@ -1,37 +1,59 @@
libexec/xfce4/panel-plugins/xfce4-battery-plugin
-share/icons/hicolor/16x16/devices/battery.png
-share/icons/hicolor/22x22/devices/battery.png
-share/icons/hicolor/24x24/devices/battery.png
-share/icons/hicolor/32x32/devices/battery.png
-share/icons/hicolor/scalable/devices/battery.svg
-share/locale/ar/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/ca/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/cs/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/da/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/de/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/el/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/en_GB/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/eu/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/fi/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/fr/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/gl/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/id/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/it/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/lv/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/nb_NO/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/pl/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/pt_BR/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/pt_PT/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/sq/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/uk/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/ur/LC_MESSAGES/xfce4-battery-plugin.mo
-share/locale/zh_TW/LC_MESSAGES/xfce4-battery-plugin.mo
+share/icons/hicolor/16x16/apps/xfce4-battery-plugin.png
+share/icons/hicolor/22x22/apps/xfce4-battery-plugin.png
+share/icons/hicolor/24x24/apps/xfce4-battery-plugin.png
+share/icons/hicolor/32x32/apps/xfce4-battery-plugin.png
+share/icons/hicolor/scalable/apps/xfce4-battery-plugin.svg
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-battery-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-battery-plugin.mo
share/xfce4/panel-plugins/battmon.desktop
@dirrmtry share/xfce4/panel-plugins
@dirrmtry share/xfce4
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/nb_NO/LC_MESSAGES
-@dirrmtry share/locale/nb_NO
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/kk
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
@dirrmtry libexec/xfce4/panel-plugins
@dirrmtry libexec/xfce4