aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zap
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-05 18:00:09 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-05 18:00:09 +0000
commit8548ef54c1c60d130130ac4fddb01ddcb4b96f67 (patch)
tree4931c41e6a5af26013d11238131c8e35265608e9 /sysutils/zap
parentf769b9ccdad4f5f3194fe32ba5e8bd56a09268c4 (diff)
downloadports-8548ef54c1c60d130130ac4fddb01ddcb4b96f67.tar.gz
ports-8548ef54c1c60d130130ac4fddb01ddcb4b96f67.zip
New port: sysutils/zap
Use zap to maintain ZFS snapshots with cron. - Uses neither configuration files nor custom ZFS properties - all information is supplied when zap is invoked and stored in snapshot names. - Uses namespaces to avoid collisions with other snapshots. - Creates and destroys snapshots only when it makes sense to. - Written in POSIX sh. WWW: https://github.com/Jehops/zap PR: 208495 Submitted by: Joseph Mingrone <jrm@ftfl.ca>
Notes
Notes: svn path=/head/; revision=412578
Diffstat (limited to 'sysutils/zap')
-rw-r--r--sysutils/zap/Makefile26
-rw-r--r--sysutils/zap/distinfo2
-rw-r--r--sysutils/zap/pkg-descr10
3 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/zap/Makefile b/sysutils/zap/Makefile
new file mode 100644
index 000000000000..733facc1809b
--- /dev/null
+++ b/sysutils/zap/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= zap
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= Maintain ZFS snapshots with cron
+
+LICENSE= BSD2CLAUSE
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= Jehops
+GH_TAGNAME= 0.1
+
+PLIST_FILES= bin/zap %%PORTDOCS%%%%DOCSDIR%%/README.org
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/zap ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.org ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/zap/distinfo b/sysutils/zap/distinfo
new file mode 100644
index 000000000000..cbf94819da97
--- /dev/null
+++ b/sysutils/zap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Jehops-zap-0.1_GH0.tar.gz) = 31aa6f579c41e399646b54116bd33aeb1a1020c41436df3c66c4226d94206014
+SIZE (Jehops-zap-0.1_GH0.tar.gz) = 2487
diff --git a/sysutils/zap/pkg-descr b/sysutils/zap/pkg-descr
new file mode 100644
index 000000000000..6f7098bd43a1
--- /dev/null
+++ b/sysutils/zap/pkg-descr
@@ -0,0 +1,10 @@
+Use zap to maintain ZFS snapshots with cron.
+
+- Uses neither configuration files nor custom ZFS properties
+- all information is supplied when zap is invoked and stored in snapshot
+ names.
+- Uses namespaces to avoid collisions with other snapshots.
+- Creates and destroys snapshots only when it makes sense to.
+- Written in POSIX sh.
+
+WWW: https://github.com/Jehops/zap