aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zidrav
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-17 19:33:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-17 19:33:31 +0000
commit491d1ba6664c6de419db38bead44f468aed582c2 (patch)
tree71bada3b50f75b8633658763b3c8972bef323a52 /sysutils/zidrav
parent5e7c256a95a3a47ab0d5352d3116a975a8abd819 (diff)
downloadports-491d1ba6664c6de419db38bead44f468aed582c2.tar.gz
ports-491d1ba6664c6de419db38bead44f468aed582c2.zip
Add zidrav, a file corruption detection and repair program. It's designed
to provide a way to fix file damage without having to redownload the entire (potentially large) file over a (potentially slow) connection. PR: ports/54650 Submitted by: Cosmin Stroe <cstroe1@uic.edu>
Notes
Notes: svn path=/head/; revision=96083
Diffstat (limited to 'sysutils/zidrav')
-rw-r--r--sysutils/zidrav/Makefile34
-rw-r--r--sysutils/zidrav/distinfo2
-rw-r--r--sysutils/zidrav/files/patch-Makefile17
-rw-r--r--sysutils/zidrav/pkg-descr8
-rw-r--r--sysutils/zidrav/pkg-plist1
5 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/zidrav/Makefile b/sysutils/zidrav/Makefile
new file mode 100644
index 000000000000..b12c0130894b
--- /dev/null
+++ b/sysutils/zidrav/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: zidrav
+# Date created: 14 July 2003
+# Whom: Cosmin Stroe <cstroe1@uic.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zidrav
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://hehipc.phy.uic.edu/~cosmin/distfiles/:MAN\
+ http://eff.dyndns.ws/distfiles/:MAN
+MASTER_SITE_SUBDIR= zidrav
+DISTNAME= zidrav4unix-1.1
+DISTFILES= zidrav4unix-1.1.tar.gz \
+ zidrav.1.gz:MAN
+EXTRACT_ONLY= zidrav4unix-1.1.tar.gz
+
+MAINTAINER= cstroe1@uic.edu
+COMMENT= A file corruption detection and repair program
+
+ALL_TARGET= zidrav
+MAN1= zidrav.1.gz
+MANCOMPRESSED= maybe
+NOMANCOMPRESS= true
+MANEXT= # empty
+NO_INSTALL_MANPAGES= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/zidrav ${PREFIX}/bin
+ ${INSTALL_MAN} ${DISTDIR}/zidrav.1.gz ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/zidrav/distinfo b/sysutils/zidrav/distinfo
new file mode 100644
index 000000000000..f06b1e2d225c
--- /dev/null
+++ b/sysutils/zidrav/distinfo
@@ -0,0 +1,2 @@
+MD5 (zidrav4unix-1.1.tar.gz) = 573492070859d417e04e257512079113
+MD5 (zidrav.1.gz) = 0a61dded771ba4b76ef23b1edae41643
diff --git a/sysutils/zidrav/files/patch-Makefile b/sysutils/zidrav/files/patch-Makefile
new file mode 100644
index 000000000000..52dc247b16d7
--- /dev/null
+++ b/sysutils/zidrav/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Mon Mar 31 02:35:26 2003
++++ Makefile Tue Jul 15 12:49:41 2003
+@@ -1,11 +1,11 @@
+ zidrav: zidrav.cpp flayer.o core.o flayer.h
+- g++ -O2 -Wall -o zidrav zidrav.cpp flayer.o core.o
++ $(CXX) $(CFLAGS) -o zidrav zidrav.cpp flayer.o core.o
+
+ flayer.o: flayer.cpp core.h
+- g++ -O2 -Wall -c flayer.cpp
++ $(CXX) $(CFLAGS) -c flayer.cpp
+
+ core.o: core.cpp core.h
+- g++ -O2 -Wall -c core.cpp
++ $(CXX) $(CFLAGS) -c core.cpp
+
+ .PHONY:
+ clean:
diff --git a/sysutils/zidrav/pkg-descr b/sysutils/zidrav/pkg-descr
new file mode 100644
index 000000000000..91f46cfa7832
--- /dev/null
+++ b/sysutils/zidrav/pkg-descr
@@ -0,0 +1,8 @@
+ZIDRAV is a file corruption detection and repair program. It's designed
+to provide a way to fix file damage without having to redownload the
+entire (potentially large) file over a (potentially slow) connection.
+
+WWW: http://sourceforge.net/projects/zidrav/
+
+- Cosmin Stroe
+cstroe1@uic.edu
diff --git a/sysutils/zidrav/pkg-plist b/sysutils/zidrav/pkg-plist
new file mode 100644
index 000000000000..c75a337068b9
--- /dev/null
+++ b/sysutils/zidrav/pkg-plist
@@ -0,0 +1 @@
+bin/zidrav