aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-02-01 02:42:05 +0000
commitae994c8ea8a59644c1a1406b0b6547826bc12791 (patch)
tree396acb34b10ac8f349be827c6eb833e0fd68cdff /sysutils
parent2c5b5e25ddd43be1ce0fe90095ab5746c431b5b4 (diff)
downloadports-ae994c8ea8a59644c1a1406b0b6547826bc12791.tar.gz
ports-ae994c8ea8a59644c1a1406b0b6547826bc12791.zip
Use libtool port instead of included version to avoid objformat a.out botch
Notes
Notes: svn path=/head/; revision=183830
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/file/Makefile1
-rw-r--r--sysutils/freeipmi/Makefile1
-rw-r--r--sysutils/fusefs-encfs/Makefile1
-rw-r--r--sysutils/fusefs-encfs/pkg-plist1
-rw-r--r--sysutils/fusefs-ntfs/Makefile1
-rw-r--r--sysutils/heartbeat/Makefile1
-rw-r--r--sysutils/heartbeat2/Makefile1
-rw-r--r--sysutils/lineak-defaultplugin/Makefile5
-rw-r--r--sysutils/userinfo/Makefile1
-rw-r--r--sysutils/userinfo/pkg-plist3
10 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/file/Makefile b/sysutils/file/Makefile
index c4ea1e94e980..7eb2d80ee5f9 100644
--- a/sysutils/file/Makefile
+++ b/sysutils/file/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.astron.com/pub/file/ \
MAINTAINER= jharris@widomaker.com
COMMENT= Utility to determine file type
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GCC= 3.4+
diff --git a/sysutils/freeipmi/Makefile b/sysutils/freeipmi/Makefile
index fdcfd5e0f1fc..dcc2498efdf3 100644
--- a/sysutils/freeipmi/Makefile
+++ b/sysutils/freeipmi/Makefile
@@ -16,6 +16,7 @@ COMMENT= Library and tools to support IPMI-capable hardware
BUILD_DEPENDS+= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 0462963eb7e2..65a0eeb7bbf1 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
WRKSRC= ${WRKDIR}/encfs-${PORTVERSION}
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
CFLAGS+= -pthread
diff --git a/sysutils/fusefs-encfs/pkg-plist b/sysutils/fusefs-encfs/pkg-plist
index 7f81a55b8c03..fb179acecd62 100644
--- a/sysutils/fusefs-encfs/pkg-plist
+++ b/sysutils/fusefs-encfs/pkg-plist
@@ -3,6 +3,7 @@ bin/encfsctl
bin/encfssh
lib/libencfs.so.2
lib/libencfs.so
+lib/libencfs.a
lib/libencfs.la
share/locale/bg/LC_MESSAGES/encfs.mo
share/locale/da/LC_MESSAGES/encfs.mo
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index f1e998f7a390..6f2ec608f334 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
BUILD_DEPENDS= fusefs-libs>=2.6.0:${PORTSDIR}/sysutils/fusefs-libs
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ONLY_FOR_ARCHS= i386 amd64
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 70b130adf47c..1a798046abf2 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
xml2.5:${PORTSDIR}/textproc/libxml2
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/sysutils/heartbeat2/Makefile b/sysutils/heartbeat2/Makefile
index 70b130adf47c..1a798046abf2 100644
--- a/sysutils/heartbeat2/Makefile
+++ b/sysutils/heartbeat2/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
xml2.5:${PORTSDIR}/textproc/libxml2
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/sysutils/lineak-defaultplugin/Makefile b/sysutils/lineak-defaultplugin/Makefile
index f5621176217a..4604f9980f46 100644
--- a/sysutils/lineak-defaultplugin/Makefile
+++ b/sysutils/lineak-defaultplugin/Makefile
@@ -17,6 +17,7 @@ COMMENT= Default plugins for lineakd
LIB_DEPENDS= lineak.8:${PORTSDIR}/sysutils/lineakd
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_XLIB= yes
@@ -26,8 +27,10 @@ CONFIGURE_ARGS+= --program-prefix=''
MAN1= lineak_defaultplugin.1
MAN_COMPRESSED= yes
-PLIST_FILES= lib/lineakd/plugins/defaultplugin.la \
+PLIST_FILES= lib/lineakd/plugins/defaultplugin.a \
+ lib/lineakd/plugins/defaultplugin.la \
lib/lineakd/plugins/defaultplugin.so \
+ lib/lineakd/plugins/mediadetectplugin.a \
lib/lineakd/plugins/mediadetectplugin.la \
lib/lineakd/plugins/mediadetectplugin.so \
etc/media-detect.conf
diff --git a/sysutils/userinfo/Makefile b/sysutils/userinfo/Makefile
index bea67db17269..0e5ef2be0012 100644
--- a/sysutils/userinfo/Makefile
+++ b/sysutils/userinfo/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://arbornet.org/~bjk/userinfo/ \
MAINTAINER= bjk@m-net.arbornet.org
COMMENT= Show information about local users
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/sysutils/userinfo/pkg-plist b/sysutils/userinfo/pkg-plist
index f4967d39a111..3ff8e22c06ff 100644
--- a/sysutils/userinfo/pkg-plist
+++ b/sysutils/userinfo/pkg-plist
@@ -1,5 +1,8 @@
bin/ui
+lib/userinfo/login.a
lib/userinfo/login.so
+lib/userinfo/mail.a
lib/userinfo/mail.so
+lib/userinfo/passwd.a
lib/userinfo/passwd.so
@dirrm lib/userinfo