aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
commitc10f314307a4e84ca4811cb03db549590b4c364a (patch)
treeaefb02047d08a1e3c25a562330070cfdd71f0579 /sysutils
parentbeaeca88a88b0f7e641416a47008edd52290575c (diff)
downloadports-c10f314307a4e84ca4811cb03db549590b4c364a.tar.gz
ports-c10f314307a4e84ca4811cb03db549590b4c364a.zip
- lang/perl5.6 is dead, remove PERL_LEVEL/PERL_VERSION < 500801 checks
PR: ports/135398 Tested by: 2 -exp runs by pav Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=238202
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/munin-main/Makefile11
-rw-r--r--sysutils/munin-master/Makefile11
-rw-r--r--sysutils/munin-node/Makefile11
-rw-r--r--sysutils/p5-Fuse-Simple/Makefile8
-rw-r--r--sysutils/psgconf/Makefile9
-rw-r--r--sysutils/rsnapshot/Makefile13
-rw-r--r--sysutils/system-tools-backends/Makefile8
-rw-r--r--sysutils/tenshi/Makefile8
8 files changed, 11 insertions, 68 deletions
diff --git a/sysutils/munin-main/Makefile b/sysutils/munin-main/Makefile
index 2c9cb0b48ed2..cf8ab9375120 100644
--- a/sysutils/munin-main/Makefile
+++ b/sysutils/munin-main/Makefile
@@ -24,15 +24,6 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
BUILD_DEPENDS= ${RUN_DEPENDS}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} <= 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
-.endif
-
USE_GMAKE= yes
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
@@ -61,4 +52,4 @@ post-install:
@${CHGRP} munin /var/run/munin /var/log/munin-main ${WWWDIR} ${PREFIX}/var/munin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 2c9cb0b48ed2..cf8ab9375120 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -24,15 +24,6 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
BUILD_DEPENDS= ${RUN_DEPENDS}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} <= 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
-.endif
-
USE_GMAKE= yes
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
@@ -61,4 +52,4 @@ post-install:
@${CHGRP} munin /var/run/munin /var/log/munin-main ${WWWDIR} ${PREFIX}/var/munin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 1fe9b92f703f..de23b71f1499 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -22,12 +22,6 @@ USE_PERL5= yes
RUN_DEPENDS= ${SITE_PERL}/Net/Server/Fork.pm:${PORTSDIR}/net/p5-Net-Server
BUILD_DEPENDS= ${RUN_DEPENDS}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
-.endif
-
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -47,9 +41,6 @@ pre-su-install:
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/munin-node.sh ${PREFIX}/etc/rc.d/munin-node.sh
-.if ${PERL_LEVEL} < 500800
- ${INSTALL_SCRIPT} ${WRKDIR}/munin-node-revive.sh ${PREFIX}/bin/munin-node-revive
-.endif
${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf ${PREFIX}/etc/munin/munin-node.conf.sample
${INSTALL_DATA} ${FILESDIR}/plugins.conf ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample
@if [ ! -f ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf ]; then \
@@ -63,4 +54,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO} ${DISTNAME} | ${SED} -e 's/munin_//' > ${PREFIX}/etc/munin/VERSION.node
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Fuse-Simple/Makefile b/sysutils/p5-Fuse-Simple/Makefile
index e2f8969a05fe..c0f54862f6e6 100644
--- a/sysutils/p5-Fuse-Simple/Makefile
+++ b/sysutils/p5-Fuse-Simple/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Fuse::Simple.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/Switch.pm:${PORTSDIR}/lang/p5-Switch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/psgconf/Makefile b/sysutils/psgconf/Makefile
index 9c5f9c473c13..bf81ae864d9f 100644
--- a/sysutils/psgconf/Makefile
+++ b/sysutils/psgconf/Makefile
@@ -182,13 +182,6 @@ MAN3= PSGConf.3 \
PSGConf::Util.3 \
psgconf-intro.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
-.endif
-
PKGINSTALL= ${WRKSRC}/postinstall
PKGDEINSTALL= ${WRKSRC}/postinstall
@@ -201,4 +194,4 @@ post-install:
@${CP} ${WRKSRC}/etc/psgconf_modules ${PREFIX}/etc/psgconf_modules.sample
PKG_PREFIX=${PREFIX} PKG_MGR=FreeBSD::Ports ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/rsnapshot/Makefile b/sysutils/rsnapshot/Makefile
index 41ea0408a708..c450501076a8 100644
--- a/sysutils/rsnapshot/Makefile
+++ b/sysutils/rsnapshot/Makefile
@@ -23,18 +23,13 @@ GNU_CONFIGURE= yes
MAN1= rsnapshot.1 rsnapshot-diff.1
PORTDOCS= AUTHORS ChangeLog README TODO
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/bin/pod2man,pod2man,' ${WRKSRC}/Makefile.in
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-post-patch:
- ${REINPLACE_CMD} -e 's,/usr/bin/pod2man,pod2man,' ${WRKSRC}/Makefile.in
-.if ${PERL_LEVEL} < 500800
- ${REINPLACE_CMD} -e "s, -n 'rsnapshot',," ${WRKSRC}/Makefile.in
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/system-tools-backends/Makefile b/sysutils/system-tools-backends/Makefile
index 52f83ddee53b..c38a2122c116 100644
--- a/sysutils/system-tools-backends/Makefile
+++ b/sysutils/system-tools-backends/Makefile
@@ -31,14 +31,8 @@ CONFIGURE_ARGS= --with-stb-group=wheel \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} <= 500800
-RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
post-configure:
@${REINPLACE_CMD} -e 's|@GETTEXT_PACKAGE@|system-tools-backends|g' \
${WRKSRC}/po/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/tenshi/Makefile b/sysutils/tenshi/Makefile
index e51832e434ec..73d48ff478ea 100644
--- a/sysutils/tenshi/Makefile
+++ b/sysutils/tenshi/Makefile
@@ -28,12 +28,6 @@ MAN8= tenshi.8
PORTDOCS= README Changelog
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-.endif
-
post-patch:
@${PERL5} -pi.bak -e ' \
s"/usr/bin/perl"${PERL}" if $$. == 1; \
@@ -50,4 +44,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>