aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-03-17 07:30:01 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-03-17 07:30:01 +0000
commitf7f73064dc37007ed63c84cf3be94000eec17881 (patch)
tree2ef0d62200e5e3d5c927eb84ee99d60c152271d6 /sysutils
parent1762997bd57be3badbcaf73076f07aaa445330c7 (diff)
downloadports-f7f73064dc37007ed63c84cf3be94000eec17881.tar.gz
ports-f7f73064dc37007ed63c84cf3be94000eec17881.zip
Add uschedule 0.7.0, a scheduler program
uschedule is not cron(8) and uschedule is not at(1) - it does offer similar functionality but is not intended to be a drop-in replacement. It works differently. It's designed to be different. WWW: http://www.ohse.de/uwe/uschedule.html PR: ports/63075 Submitted by: Thomas Seck <tmseck@netcologne.de>
Notes
Notes: svn path=/head/; revision=104258
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/uschedule/Makefile50
-rw-r--r--sysutils/uschedule/distinfo2
-rw-r--r--sysutils/uschedule/files/patch-src-uschedule_intro.7.in8
-rw-r--r--sysutils/uschedule/files/patch-src-uscheduled.c18
-rw-r--r--sysutils/uschedule/pkg-descr5
-rw-r--r--sysutils/uschedule/pkg-message12
7 files changed, 96 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 84ed28790041..45bb61821fdc 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -363,6 +363,7 @@
SUBDIR += upsd
SUBDIR += upsmon
SUBDIR += uptimed
+ SUBDIR += uschedule
SUBDIR += userinfo
SUBDIR += userlist
SUBDIR += usermin
diff --git a/sysutils/uschedule/Makefile b/sysutils/uschedule/Makefile
new file mode 100644
index 000000000000..ae1e7db40206
--- /dev/null
+++ b/sysutils/uschedule/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: uschedule
+# Date created: 2004-02-19
+# Whom: Thomas Seck <tmseck@netcologne.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uschedule
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.ohse.de/uwe/uschedule/
+
+MAINTAINER= tmseck@netcologne.de
+COMMENT= A scheduler program, designed to replace cron(8) and at(1)
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/tai64nlocal:${PORTSDIR}/sysutils/daemontools
+RUN_DEPENDS= ${LOCALBASE}/bin/multilog:${PORTSDIR}/sysutils/daemontools
+
+DISABLE_SIZE= yes
+WRKSRC= ${WRKDIR}/admin/${DISTNAME}
+
+MAN1= uschedule.1 uschedulecmd.1 uscheduleconf.1 uschedulecp.1 \
+ uscheduleedit.1 uschedulelist.1 uschedulerm.1
+MAN7= uschedule_intro.7
+MAN8= uscheduled.8
+PORTDOCS= ChangeLog NEWS SECURITY-BUG
+bin= uschedule uschedulecmd uscheduleconf uschedulecp \
+ uscheduleedit uschedulelist uschedulerm
+sbin= uscheduled
+PLIST_FILES= ${bin:S/^/bin\//}
+PLIST_FILES+= ${sbin:S/^/sbin\//}
+
+do-build:
+ cd ${WRKSRC} && package/compile && package/check
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/src && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+.for section in 1 7 8
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN${section}} \
+ ${MAN${section}PREFIX}/man/man${section}
+.endfor
+.for d in bin sbin
+ cd ${WRKSRC}/compile && ${INSTALL_PROGRAM} ${${d}} ${PREFIX}/${d}
+.endfor
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/sysutils/uschedule/distinfo b/sysutils/uschedule/distinfo
new file mode 100644
index 000000000000..772eea56e0f3
--- /dev/null
+++ b/sysutils/uschedule/distinfo
@@ -0,0 +1,2 @@
+MD5 (uschedule-0.7.0.tar.gz) = a91fbf7b6971b033687a234edfde5da7
+SIZE (uschedule-0.7.0.tar.gz) = 72573
diff --git a/sysutils/uschedule/files/patch-src-uschedule_intro.7.in b/sysutils/uschedule/files/patch-src-uschedule_intro.7.in
new file mode 100644
index 000000000000..740801551bc5
--- /dev/null
+++ b/sysutils/uschedule/files/patch-src-uschedule_intro.7.in
@@ -0,0 +1,8 @@
+--- src/uschedule_intro.7.in.orig Sat Oct 20 10:46:48 2001
++++ src/uschedule_intro.7.in Mon Nov 25 10:03:02 2002
+@@ -1,4 +1,4 @@
+-.TH uschedule_intro 1 \*(VE \*(PA
++.TH uschedule_intro 7 \*(VE \*(PA
+ .hy 0
+ .URL "Uwe Ohse" ../uwe.html
+ .br
diff --git a/sysutils/uschedule/files/patch-src-uscheduled.c b/sysutils/uschedule/files/patch-src-uscheduled.c
new file mode 100644
index 000000000000..027a5965ef0c
--- /dev/null
+++ b/sysutils/uschedule/files/patch-src-uscheduled.c
@@ -0,0 +1,18 @@
+--- src/uscheduled.c.orig Tue Mar 4 08:26:56 2003
++++ src/uscheduled.c Sun Nov 2 21:02:00 2003
+@@ -161,9 +161,14 @@
+ static iopause_fd iop[1];
+ static void fifo_open(void)
+ {
++ static int fd2=-1;
++ if (-1!=fd2) close(fd2);
+ iop[0].fd=open_read("fifo");
+ if (-1==iop[0].fd)
+- xbailout(111,errno,"failed to open fifo",0,0,0);
++ xbailout(111,errno,"failed to open_read fifo",0,0,0);
++ fd2=open_write("fifo");
++ if (-1==fd2)
++ xbailout(111,errno,"failed to open_write fifo",0,0,0);
+ ndelay_on(iop[0].fd);
+ iop[0].events=IOPAUSE_READ;
+ }
diff --git a/sysutils/uschedule/pkg-descr b/sysutils/uschedule/pkg-descr
new file mode 100644
index 000000000000..399a9e91aaa5
--- /dev/null
+++ b/sysutils/uschedule/pkg-descr
@@ -0,0 +1,5 @@
+uschedule is not cron and uschedule is not at - it does offer similar
+functionality but is not intended to be a drop-in replacement. It works
+differently. It's designed to be different.
+
+WWW: http://www.ohse.de/uwe/uschedule.html
diff --git a/sysutils/uschedule/pkg-message b/sysutils/uschedule/pkg-message
new file mode 100644
index 000000000000..e0933d6792de
--- /dev/null
+++ b/sysutils/uschedule/pkg-message
@@ -0,0 +1,12 @@
+
+Post-installation information:
+
+Please read uschedule_intro(7) and visit http://www.ohse.de/uwe/uschedule.html
+for further and maybe more up-to-date information.
+
+To stop cron(8) from being started at system boot, specify
+
+cron_enable=NO
+
+in /etc/rc.conf. See rc.conf(5) and /etc/defaults/rc.conf for further
+information.