aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1998-11-24 22:43:40 +0000
committerBill Fumerola <billf@FreeBSD.org>1998-11-24 22:43:40 +0000
commit4a23f30b9f6bf28846683644707c6c6415bef4f4 (patch)
treebcbb1d124acc6f37f34c8e50917b3affdcf8a139 /sysutils
parente709d103a7645d003b6d8900b72a47ee43449af1 (diff)
downloadports-4a23f30b9f6bf28846683644707c6c6415bef4f4.tar.gz
ports-4a23f30b9f6bf28846683644707c6c6415bef4f4.zip
Initial import of ports/sysutils/upsmon
Designed specifically for the APC SmartUPS devices, the software is dependent on the SmartUPS interface and will only function with SmartUPS devices. Essentially, this is a simpler version of upsd.
Notes
Notes: svn path=/head/; revision=14877
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/upsmon/Makefile34
-rw-r--r--sysutils/upsmon/distinfo1
-rw-r--r--sysutils/upsmon/files/patch-aa20
-rw-r--r--sysutils/upsmon/files/upsmon.sh7
-rw-r--r--sysutils/upsmon/pkg-comment1
-rw-r--r--sysutils/upsmon/pkg-descr8
-rw-r--r--sysutils/upsmon/pkg-message9
-rw-r--r--sysutils/upsmon/pkg-plist5
8 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/upsmon/Makefile b/sysutils/upsmon/Makefile
new file mode 100644
index 000000000000..f69080539fcc
--- /dev/null
+++ b/sysutils/upsmon/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: upsmon
+# Version required: 2.1.3
+# Date created: 5 Oct 1998
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $Id: $
+#
+
+DISTNAME= upsmon-2.1.3
+CATEGORIES= sysutils
+MASTER_SITES= ftp://newcorridor.com/pub/upsmon/
+
+MAINTAINER= ports@FreeBSD.org
+
+MAKEFILE= makefile.bsdi
+NO_PACKAGE= "must provide without modifications"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/upsstat ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/upsmond ${PREFIX}/sbin
+
+ ${SED} -e 's#!!PREFIX!!#${PREFIX}#g' ${FILESDIR}/upsmon.sh \
+ > ${PREFIX}/etc/rc.d/upsmon.sh
+ @chmod +x ${PREFIX}/etc/rc.d/upsmon.sh
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/upsmon
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/upsmon
+.endif
+
+post-install:
+ ${SED} -e 's#/usr/local#${PREFIX}#' ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/sysutils/upsmon/distinfo b/sysutils/upsmon/distinfo
new file mode 100644
index 000000000000..ef794febf6f2
--- /dev/null
+++ b/sysutils/upsmon/distinfo
@@ -0,0 +1 @@
+MD5 (upsmon-2.1.3.tar.gz) = 2ab764327dcb1cef58a1c8d2745a3884
diff --git a/sysutils/upsmon/files/patch-aa b/sysutils/upsmon/files/patch-aa
new file mode 100644
index 000000000000..79d209ae5b17
--- /dev/null
+++ b/sysutils/upsmon/files/patch-aa
@@ -0,0 +1,20 @@
+--- makefile.bsdi.orig Wed Aug 5 01:18:38 1998
++++ makefile.bsdi Mon Oct 5 20:11:38 1998
+@@ -33,13 +33,13 @@
+ .SUFFIXES: .cc .o #rules for .c and .o
+
+ CC = gcc
+-CFLAGS_DEBUG = -O2 -Wall -DDEBUG -g
+-CFLAGS_NODEBUG = -O2 -Wall -g
++CFLAGS_DEBUG = -DDEBUG
++CFLAGS_NODEBUG =
+
+ .ifdef DEBUG
+-CFLAGS = $(CFLAGS_DEBUG)
++CFLAGS += $(CFLAGS_DEBUG)
+ .else
+-CFLAGS = $(CFLAGS_NODEBUG)
++CFLAGS += $(CFLAGS_NODEBUG)
+ .endif
+
+ UPSMOND_TARGET = upsmond
diff --git a/sysutils/upsmon/files/upsmon.sh b/sysutils/upsmon/files/upsmon.sh
new file mode 100644
index 000000000000..eb59e9acfee5
--- /dev/null
+++ b/sysutils/upsmon/files/upsmon.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# see !!PREFIX!!/share/doc/upsmon/INSTALL for command line option details
+
+if [ -x !!PREFIX!!/sbin/upsmon ]; then
+ !!PREFIX!!/sbin/upsmon -p /dev/cuaa0 && echo -n ' upsmond'
+fi
diff --git a/sysutils/upsmon/pkg-comment b/sysutils/upsmon/pkg-comment
new file mode 100644
index 000000000000..21d92cfb40d7
--- /dev/null
+++ b/sysutils/upsmon/pkg-comment
@@ -0,0 +1 @@
+Basic UPS monitor for the APC SmartUPS devices.
diff --git a/sysutils/upsmon/pkg-descr b/sysutils/upsmon/pkg-descr
new file mode 100644
index 000000000000..607cdcb2f79d
--- /dev/null
+++ b/sysutils/upsmon/pkg-descr
@@ -0,0 +1,8 @@
+Designed specifically for the APC SmartUPS devices, the
+software is dependent on the SmartUPS interface and will
+only function with SmartUPS devices.
+
+Provides the basic functions.
+
+-- Igor
+igor@zynaps.ru
diff --git a/sysutils/upsmon/pkg-message b/sysutils/upsmon/pkg-message
new file mode 100644
index 000000000000..91b8dca3783b
--- /dev/null
+++ b/sysutils/upsmon/pkg-message
@@ -0,0 +1,9 @@
+
+upsmon has been installed.
+
+See /usr/local/share/doc/upsmon/INSTALL for command line
+option details.
+
+NOTE: upsmond will dump core if you start upsstat without
+ SmartUPS properly attached to the specified port.
+
diff --git a/sysutils/upsmon/pkg-plist b/sysutils/upsmon/pkg-plist
new file mode 100644
index 000000000000..3eb31901831c
--- /dev/null
+++ b/sysutils/upsmon/pkg-plist
@@ -0,0 +1,5 @@
+bin/upsstat
+sbin/upsmond
+etc/rc.d/upsmon.sh
+share/doc/upsmon/INSTALL
+@dirrm share/doc/upsmon