aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1998-11-19 21:59:54 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1998-11-19 21:59:54 +0000
commit8d17459076785cab5c488b881587212190b6e8d3 (patch)
tree07ccbe52b5a710b1cbb57ce2a7c881d7042f765f /sysutils
parenta967e4b77632aacfaea64a42884d96d015ca1810 (diff)
downloadports-8d17459076785cab5c488b881587212190b6e8d3.tar.gz
ports-8d17459076785cab5c488b881587212190b6e8d3.zip
Check if webserver is installed
Warn user if no webserver is installed Recommend apache13-php or apache13-modssl. the php version can be configured to use the modssl module as well ...
Notes
Notes: svn path=/head/; revision=14700
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index c428b2d24d38..f89bd4ed20db 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -3,7 +3,7 @@
# Date created: Do 19 Nov 1998 21:13:55 CET
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.1.1.1 1998/11/19 21:38:24 andreas Exp $
+# $Id: Makefile,v 1.2 1998/11/19 21:41:15 andreas Exp $
#
DISTNAME= webmin-0.64
@@ -16,6 +16,16 @@ NO_BUILD= yes
IS_INTERACTIVE= yes
USE_PERL5= yes
+pre-extract:
+ @if [ -x ${PREFIX}/sbin/httpd ]; then \
+ echo Good ! You seem to have apache webserver installed ...; \
+ else \
+ echo You need to install one of the different apache webservers; \
+ echo Best would be apache13-modssl or apache13-php3 that can be; \
+ echo configured to use modssl for better security as well; \
+ exit 1; \
+ fi
+
do-install:
${MKDIR} ${PREFIX}/lib/webmin
${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin