aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2008-04-13 19:08:36 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2008-04-13 19:08:36 +0000
commit0491e1d2120f78baea4b29705f120ad975e2f907 (patch)
tree04f6705125333b0727ca7f5075cc161be7b2f643 /sysutils
parent518e244fb8265d9395465df0c9db2302417a5a0e (diff)
downloadports-0491e1d2120f78baea4b29705f120ad975e2f907.tar.gz
ports-0491e1d2120f78baea4b29705f120ad975e2f907.zip
Work around the assumption that openat() implies the existence of
fdopendir(). FreeBSD 8 has the former, but not the latter. PR: 122433 Approved by: maintainer
Notes
Notes: svn path=/head/; revision=211187
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/coreutils/Makefile3
-rw-r--r--sysutils/coreutils/files/patch-lib_getcwd.c13
2 files changed, 16 insertions, 0 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index 55b1089266bf..fa82be60c65a 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -24,6 +24,9 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+# GNU assumes that openat() implies the existence of fdopendir(),
+# which does not hold true on FreeBSD 8.
+CONFIGURE_ENV+= ac_cv_func_openat=no
USE_GMAKE= yes
diff --git a/sysutils/coreutils/files/patch-lib_getcwd.c b/sysutils/coreutils/files/patch-lib_getcwd.c
new file mode 100644
index 000000000000..8df1a66b9775
--- /dev/null
+++ b/sysutils/coreutils/files/patch-lib_getcwd.c
@@ -0,0 +1,13 @@
+--- lib/getcwd.c.orig 2008-04-11 20:06:03.000000000 +0200
++++ lib/getcwd.c 2008-04-11 20:06:29.000000000 +0200
+@@ -30,6 +30,10 @@
+
+ #include <fcntl.h> /* For AT_FDCWD on Solaris 9. */
+
++#ifdef __FreeBSD__
++# undef AT_FDCWD
++#endif
++
+ #ifndef __set_errno
+ # define __set_errno(val) (errno = (val))
+ #endif