aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-12-29 16:24:43 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-12-29 16:24:43 +0000
commit2b144cb24b3e2e991e095628a4965377f080d13f (patch)
treea118293b8c40ed2f9f034631f11878cdf8825e21 /sysutils
parent2e505f0a092fa8fa824683014f35aa38e1de57fe (diff)
downloadports-2b144cb24b3e2e991e095628a4965377f080d13f.tar.gz
ports-2b144cb24b3e2e991e095628a4965377f080d13f.zip
- now it does install Unix::ConfigFile.3 in perl5.005.
Thanks to tobez@, who suggest and teach me to solve the problem, not just move the problem to /dev/null.
Notes
Notes: svn path=/head/; revision=125443
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/p5-Unix-ConfigFile/Makefile6
-rw-r--r--sysutils/p5-Unix-ConfigFile/files/extra-patch-perl5.00512
2 files changed, 16 insertions, 2 deletions
diff --git a/sysutils/p5-Unix-ConfigFile/Makefile b/sysutils/p5-Unix-ConfigFile/Makefile
index 82ebd0073698..d061a4af5f81 100644
--- a/sysutils/p5-Unix-ConfigFile/Makefile
+++ b/sysutils/p5-Unix-ConfigFile/Makefile
@@ -18,12 +18,14 @@ COMMENT= Perl modules that provides a simple interface to reading /etc files
PERL_CONFIGURE= yes
MAN3= Unix::GroupFile.3 Unix::AliasFile.3 \
+ Unix::ConfigFile.3 \
Unix::PasswdFile.3 Unix::AutomountFile.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} >= 500601
-MAN3+= Unix::ConfigFile.3
+.if ${PERL_LEVEL} < 500601
+post-patch:
+ @cd ${WRKSRC} && ${PATCH} < ${PATCHDIR}/extra-patch-perl5.005
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Unix-ConfigFile/files/extra-patch-perl5.005 b/sysutils/p5-Unix-ConfigFile/files/extra-patch-perl5.005
new file mode 100644
index 000000000000..e86e1916c550
--- /dev/null
+++ b/sysutils/p5-Unix-ConfigFile/files/extra-patch-perl5.005
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig Fri Apr 16 04:32:54 1999
++++ Makefile.PL Thu Dec 30 00:09:35 2004
+@@ -4,4 +4,9 @@
+ WriteMakefile(
+ 'NAME' => 'Unix::ConfigFile',
+ 'VERSION_FROM' => 'ConfigFile.pm', # finds $VERSION
++ 'MAN3PODS' => {'AliasFile.pm' => 'blib/man3/Unix::AliasFile.3',
++ 'ConfigFile.pm' => 'blib/man3/Unix::ConfigFile.3',
++ 'PasswdFile.pm' => 'blib/man3/Unix::PasswdFile.3',
++ 'AutomountFile.pm' => 'blib/man3/Unix::AutomountFile.3',
++ 'GroupFile.pm' => 'blib/man3/Unix::GroupFile.3'}
+ );