aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2004-07-03 09:11:54 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2004-07-03 09:11:54 +0000
commit7fdacad5dffbdedfa0bafa1f33a0bfc45fae948e (patch)
tree60f383bb1b57512e018fc82ce7a460ba881b0f92 /sysutils
parente331461bccc98f5f5b25f0da605a13ba52e55a6f (diff)
downloadports-7fdacad5dffbdedfa0bafa1f33a0bfc45fae948e.tar.gz
ports-7fdacad5dffbdedfa0bafa1f33a0bfc45fae948e.zip
o) Fix build error in console.c with readline support
PR: - Submitted by: Kris Kennaway <kris@obsecurity.org>
Notes
Notes: svn path=/head/; revision=112841
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server/Makefile1
-rw-r--r--sysutils/bacula-server/files/patch-src-console-console.c63
-rw-r--r--sysutils/bacula/Makefile1
-rw-r--r--sysutils/bacula/files/patch-src-console-console.c63
4 files changed, 128 insertions, 0 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 12d91dc2c39d..99f31c5ded43 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bacula
PORTVERSION= 1.34.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
diff --git a/sysutils/bacula-server/files/patch-src-console-console.c b/sysutils/bacula-server/files/patch-src-console-console.c
new file mode 100644
index 000000000000..bbdf05da6702
--- /dev/null
+++ b/sysutils/bacula-server/files/patch-src-console-console.c
@@ -0,0 +1,63 @@
+*** src/console/console.c.orig Sun Jun 20 13:43:02 2004
+--- src/console/console.c Sat Jul 3 10:48:13 2004
+***************
+*** 63,69 ****
+
+ /* Forward referenced functions */
+ static void terminate_console(int sig);
+! int get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec);
+ static int do_outputcmd(FILE *input, BSOCK *UA_sock);
+ void senditf(const char *fmt, ...);
+ void sendit(const char *buf);
+--- 63,69 ----
+
+ /* Forward referenced functions */
+ static void terminate_console(int sig);
+! int get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec);
+ static int do_outputcmd(FILE *input, BSOCK *UA_sock);
+ void senditf(const char *fmt, ...);
+ void sendit(const char *buf);
+***************
+*** 200,206 ****
+
+ static void read_and_process_input(FILE *input, BSOCK *UA_sock)
+ {
+! const char *prompt = "*";
+ bool at_prompt = false;
+ int tty_input = isatty(fileno(input));
+ int stat;
+--- 200,206 ----
+
+ static void read_and_process_input(FILE *input, BSOCK *UA_sock)
+ {
+! char *prompt = "*";
+ bool at_prompt = false;
+ int tty_input = isatty(fileno(input));
+ int stat;
+***************
+*** 499,510 ****
+ #ifdef HAVE_READLINE
+ #define READLINE_LIBRARY 1
+ #undef free
+ #include "readline.h"
+ #include "history.h"
+
+-
+ int
+! get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec)
+ {
+ char *line;
+
+--- 499,510 ----
+ #ifdef HAVE_READLINE
+ #define READLINE_LIBRARY 1
+ #undef free
++ #include <stdio.h>
+ #include "readline.h"
+ #include "history.h"
+
+ int
+! get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec)
+ {
+ char *line;
+
diff --git a/sysutils/bacula/Makefile b/sysutils/bacula/Makefile
index 12d91dc2c39d..99f31c5ded43 100644
--- a/sysutils/bacula/Makefile
+++ b/sysutils/bacula/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bacula
PORTVERSION= 1.34.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
diff --git a/sysutils/bacula/files/patch-src-console-console.c b/sysutils/bacula/files/patch-src-console-console.c
new file mode 100644
index 000000000000..bbdf05da6702
--- /dev/null
+++ b/sysutils/bacula/files/patch-src-console-console.c
@@ -0,0 +1,63 @@
+*** src/console/console.c.orig Sun Jun 20 13:43:02 2004
+--- src/console/console.c Sat Jul 3 10:48:13 2004
+***************
+*** 63,69 ****
+
+ /* Forward referenced functions */
+ static void terminate_console(int sig);
+! int get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec);
+ static int do_outputcmd(FILE *input, BSOCK *UA_sock);
+ void senditf(const char *fmt, ...);
+ void sendit(const char *buf);
+--- 63,69 ----
+
+ /* Forward referenced functions */
+ static void terminate_console(int sig);
+! int get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec);
+ static int do_outputcmd(FILE *input, BSOCK *UA_sock);
+ void senditf(const char *fmt, ...);
+ void sendit(const char *buf);
+***************
+*** 200,206 ****
+
+ static void read_and_process_input(FILE *input, BSOCK *UA_sock)
+ {
+! const char *prompt = "*";
+ bool at_prompt = false;
+ int tty_input = isatty(fileno(input));
+ int stat;
+--- 200,206 ----
+
+ static void read_and_process_input(FILE *input, BSOCK *UA_sock)
+ {
+! char *prompt = "*";
+ bool at_prompt = false;
+ int tty_input = isatty(fileno(input));
+ int stat;
+***************
+*** 499,510 ****
+ #ifdef HAVE_READLINE
+ #define READLINE_LIBRARY 1
+ #undef free
+ #include "readline.h"
+ #include "history.h"
+
+-
+ int
+! get_cmd(FILE *input, const char *prompt, BSOCK *sock, int sec)
+ {
+ char *line;
+
+--- 499,510 ----
+ #ifdef HAVE_READLINE
+ #define READLINE_LIBRARY 1
+ #undef free
++ #include <stdio.h>
+ #include "readline.h"
+ #include "history.h"
+
+ int
+! get_cmd(FILE *input, char *prompt, BSOCK *sock, int sec)
+ {
+ char *line;
+