aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2011-12-10 18:49:25 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2011-12-10 18:49:25 +0000
commit8f01e7905a3a6a465663be539a032b9db084e32d (patch)
tree7442964c641821503960788f2b388de6300ce621 /sysutils
parent60a231f221c50a9e585000c9cd9e7eec5316de10 (diff)
downloadports-8f01e7905a3a6a465663be539a032b9db084e32d.tar.gz
ports-8f01e7905a3a6a465663be539a032b9db084e32d.zip
Use ViM as a more(1)/less(1) pager replacement.
To set as your default pager, export PAGER=vimpager in your shell's rcfile. See the manpage for various options. Of note, custom .vimrc files seem to cause strange behaviour. Creating ~/.vimpagerrc will give you a clean ViM environment. WWW: http://www.vim.org/scripts/script.php?script_id=1723 Feature safe: yes
Notes
Notes: svn path=/head/; revision=287154
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/vimpager/Makefile34
-rw-r--r--sysutils/vimpager/distinfo2
-rw-r--r--sysutils/vimpager/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b798c8432e1f..cf5f3ca41559 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -921,6 +921,7 @@
SUBDIR += videogen
SUBDIR += vii
SUBDIR += vils
+ SUBDIR += vimpager
SUBDIR += virtualmin
SUBDIR += vlogger
SUBDIR += vobcopy
diff --git a/sysutils/vimpager/Makefile b/sysutils/vimpager/Makefile
new file mode 100644
index 000000000000..2ca14c36aad1
--- /dev/null
+++ b/sysutils/vimpager/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: vimpager
+# Date created: 10 December 2011
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vimpager
+PORTVERSION= 1.6.3
+CATEGORIES= sysutils
+MASTER_SITES= https://github.com/${GH_DEVELOPER}/${GH_PORTNAME}/tarball/${DISTVERSION}/
+DISTNAME= ${GH_DEVELOPER}-${GH_PORTNAME}-${DISTVERSION}-0-g${GH_VERSION}
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Use ViM as a pager
+
+RUN_DEPENDS= vim:${PORTSDIR}/editors/vim
+
+# Github makes this very confusing
+GH_PORTNAME= ${PORTNAME}
+GH_DEVELOPER= rkitover #GH trees live under a username
+GH_VERSION= f381bf4d64 #GH appends a commit hash to the filename
+GH_SRCDIR= ff3b7df #GH appends something else (??) to the extracted pathname
+WRKSRC= ${WRKDIR}/${GH_DEVELOPER}-${GH_PORTNAME}-${GH_SRCDIR}
+FETCH_ARGS= -prR #GH issues HTTP/302 errors for source tarballs
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/vimpager/distinfo b/sysutils/vimpager/distinfo
new file mode 100644
index 000000000000..abdda8d11577
--- /dev/null
+++ b/sysutils/vimpager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rkitover-vimpager-1.6.3-0-gf381bf4d64.tar.gz) = 5a2884dbafad75d840d391f200a81a1516428337c99fbaf578178e3b2cbe40d7
+SIZE (rkitover-vimpager-1.6.3-0-gf381bf4d64.tar.gz) = 4861
diff --git a/sysutils/vimpager/pkg-descr b/sysutils/vimpager/pkg-descr
new file mode 100644
index 000000000000..d01a43872c56
--- /dev/null
+++ b/sysutils/vimpager/pkg-descr
@@ -0,0 +1,10 @@
+Use ViM as a more(1)/less(1) pager replacement.
+
+To set as your default pager, export PAGER=vimpager in your shell's
+rcfile.
+
+See the manpage for various options. Of note, custom .vimrc files seem
+to cause strange behaviour. Creating ~/.vimpagerrc will give you a clean
+ViM environment.
+
+WWW: http://www.vim.org/scripts/script.php?script_id=1723