aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-13 03:21:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-13 03:21:45 +0000
commita36fd42547a7d67e6f41e85f318c615b86dccef8 (patch)
treeb83b9939c004329ba40f94af991bca10c2f6a33d /sysutils
parentdbd557a145c7d64b7cc80ed25109cd56f7830f61 (diff)
downloadports-a36fd42547a7d67e6f41e85f318c615b86dccef8.tar.gz
ports-a36fd42547a7d67e6f41e85f318c615b86dccef8.zip
Add gconf-editor, a gconf database editor from GNOME 2.0.
Notes
Notes: svn path=/head/; revision=58986
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/gconf-editor/Makefile36
-rw-r--r--sysutils/gconf-editor/distinfo1
-rw-r--r--sysutils/gconf-editor/pkg-comment1
-rw-r--r--sysutils/gconf-editor/pkg-descr2
-rw-r--r--sysutils/gconf-editor/pkg-plist18
6 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3357e2db6089..8d9b6a1bd17b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -63,6 +63,7 @@
SUBDIR += fsck_ext2fs
SUBDIR += ftrace
SUBDIR += gcombust
+ SUBDIR += gconf-editor
SUBDIR += gfslicer
SUBDIR += gkrellflynn
SUBDIR += gkrellm
diff --git a/sysutils/gconf-editor/Makefile b/sysutils/gconf-editor/Makefile
new file mode 100644
index 000000000000..81f74121a568
--- /dev/null
+++ b/sysutils/gconf-editor/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gconf-editor
+# Date created: 12 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gconf-editor
+PORTVERSION= 0.1
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020509
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gconf-2.5:${PORTSDIR}/devel/gconf2
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/sysutils/gconf-editor/distinfo b/sysutils/gconf-editor/distinfo
new file mode 100644
index 000000000000..53f8b1a19031
--- /dev/null
+++ b/sysutils/gconf-editor/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gconf-editor-0.1.tar.bz2) = 1db6f1a8a585272056b4eb57c20809dd
diff --git a/sysutils/gconf-editor/pkg-comment b/sysutils/gconf-editor/pkg-comment
new file mode 100644
index 000000000000..781bc9fa449e
--- /dev/null
+++ b/sysutils/gconf-editor/pkg-comment
@@ -0,0 +1 @@
+A gconf database editor for the GNOME 2.0 environment
diff --git a/sysutils/gconf-editor/pkg-descr b/sysutils/gconf-editor/pkg-descr
new file mode 100644
index 000000000000..f840cc1d25d8
--- /dev/null
+++ b/sysutils/gconf-editor/pkg-descr
@@ -0,0 +1,2 @@
+gconf-editor is a gconf database editor for GNOME 2.0. It is similar to
+regedit on Windows.
diff --git a/sysutils/gconf-editor/pkg-plist b/sysutils/gconf-editor/pkg-plist
new file mode 100644
index 000000000000..f03d3c86cde2
--- /dev/null
+++ b/sysutils/gconf-editor/pkg-plist
@@ -0,0 +1,18 @@
+bin/gconf-editor
+share/gnome/applications/gconf-editor.desktop
+share/gnome/pixmaps/gconf-editor.png
+share/gnome/pixmaps/gconf-editor/about-logo.png
+share/gnome/pixmaps/gconf-editor/entry-blank.png
+share/gnome/pixmaps/gconf-editor/entry-bool.png
+share/gnome/pixmaps/gconf-editor/entry-list.png
+share/gnome/pixmaps/gconf-editor/entry-number.png
+share/gnome/pixmaps/gconf-editor/entry-schema.png
+share/gnome/pixmaps/gconf-editor/entry-string.png
+share/gnome/pixmaps/gconf-editor/folder-closed.png
+share/gnome/pixmaps/gconf-editor/folder-open.png
+share/gnome/pixmaps/gconf-editor/stock-about-16.png
+share/locale/az/LC_MESSAGES/gconf-editor.mo
+share/locale/ms/LC_MESSAGES/gconf-editor.mo
+share/locale/no/LC_MESSAGES/gconf-editor.mo
+share/locale/sv/LC_MESSAGES/gconf-editor.mo
+@dirrm share/gnome/pixmaps/gconf-editor