aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-11-30 04:49:03 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-11-30 04:49:03 +0000
commitbfdf4cc7cf10090e748c3cee628ff64a4a7fdcf3 (patch)
treef939324ac34e2bf0b25879f091eccd77b39eeb5d /sysutils
parent9fe263ae96998d6ccba0a1140420aa07dd8e23f7 (diff)
downloadports-bfdf4cc7cf10090e748c3cee628ff64a4a7fdcf3.tar.gz
ports-bfdf4cc7cf10090e748c3cee628ff64a4a7fdcf3.zip
EasyPBI makes creating Push Button Installer modules and packages
a simple process with a simple point-n-click interface. WWW: http://makeapbi.sf.net PR: ports/162341 Submitted by: Jesse <jessefrgsmith@yahoo.ca> Feature safe: yes
Notes
Notes: svn path=/head/; revision=286652
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/easypbi/Makefile38
-rw-r--r--sysutils/easypbi/distinfo2
-rw-r--r--sysutils/easypbi/files/pkg-message.in13
-rw-r--r--sysutils/easypbi/pkg-descr4
-rw-r--r--sysutils/easypbi/pkg-plist4
6 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 08af87cd7478..dc52ccae72fa 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -193,6 +193,7 @@
SUBDIR += dvtm
SUBDIR += dwatch
SUBDIR += e2fsprogs
+ SUBDIR += easypbi
SUBDIR += eiciel
SUBDIR += eject
SUBDIR += empower
diff --git a/sysutils/easypbi/Makefile b/sysutils/easypbi/Makefile
new file mode 100644
index 000000000000..8c986faa646b
--- /dev/null
+++ b/sysutils/easypbi/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: easypbi
+# Date created: 2011-11-29
+# Whom: jessefrgsmith@yahoo.ca
+#
+# $FreeBSD$
+#
+
+PORTNAME= easypbi
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= SF/makeapbi/${PORTNAME}/
+
+MAINTAINER= jessefrgsmith@yahoo.ca
+COMMENT= Graphical PBI module and package creator
+
+LIB_DEPENDS= Imath.6:${PORTSDIR}/graphics/ilmbase \
+ IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ jasper.4:${PORTSDIR}/graphics/jasper \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build \
+ linguist_build assistant_run qt3support \
+ dbus designer gui help-tools network script \
+ sql svg xml webkit
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/EasyPBI
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} -recursive PREFIX=${PREFIX} EasyPBI.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/EasyPBI ${PREFIX}/bin/EasyPBI
+ @${MKDIR} ${DATADIR}/../pbimaker
+ @${INSTALL_DATA} ${WRKSRC}/defaulticon.png ${DATADIR}/../pbimaker/
+
+.include <bsd.port.mk>
diff --git a/sysutils/easypbi/distinfo b/sysutils/easypbi/distinfo
new file mode 100644
index 000000000000..55069a719cc6
--- /dev/null
+++ b/sysutils/easypbi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (easypbi-0.3.tar.gz) = 63d2a23f1eea0eafa919dfd82533a602c559d0fa6720fd4dbeef77a840568608
+SIZE (easypbi-0.3.tar.gz) = 16322
diff --git a/sysutils/easypbi/files/pkg-message.in b/sysutils/easypbi/files/pkg-message.in
new file mode 100644
index 000000000000..b70c159b8cef
--- /dev/null
+++ b/sysutils/easypbi/files/pkg-message.in
@@ -0,0 +1,13 @@
+************************************************************
+
+EasyPBI has been successfully installed on your system.
+You can now create your pbi-modules.
+
+You will need to add ports-mgmt/pbi-manager to build and
+use PBIs on FreeBSD.
+
+Building from modules is not supported through EasyPBI on
+bare FreeBSD.
+
+************************************************************
+
diff --git a/sysutils/easypbi/pkg-descr b/sysutils/easypbi/pkg-descr
new file mode 100644
index 000000000000..e693efb28d4e
--- /dev/null
+++ b/sysutils/easypbi/pkg-descr
@@ -0,0 +1,4 @@
+EasyPBI makes creating Push Button Installer modules and packages
+a simple process with a simple point-n-click interface.
+
+WWW: http://makeapbi.sf.net
diff --git a/sysutils/easypbi/pkg-plist b/sysutils/easypbi/pkg-plist
new file mode 100644
index 000000000000..54ecfcd6b9cb
--- /dev/null
+++ b/sysutils/easypbi/pkg-plist
@@ -0,0 +1,4 @@
+bin/EasyPBI
+share/pbimaker/defaulticon.png
+@dirrmtry %%DATADIR%%
+@dirrmtry share/pbimaker