aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2011-11-30 22:20:54 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2011-11-30 22:20:54 +0000
commiteb17f2dda494e92c9141ce29120e5be70148e6cc (patch)
treee806e8e1e5150887936201152a8406937a52355c /sysutils
parent6e7db9cfaa27ddb364c135ac9b32b6ce21c27562 (diff)
downloadports-eb17f2dda494e92c9141ce29120e5be70148e6cc.tar.gz
ports-eb17f2dda494e92c9141ce29120e5be70148e6cc.zip
Feather is a tarsnap wrapper script that performs and maintains a
set of backups as defined by a YAML configuration file. Features: - Dynamic scheduling - Keep an arbitrary number of backups of each schedule type - Restrict schedules based on time of day - Restrict feather run to a certain amount of wall time (max_runtime) - Multiple backup paths per tarsnap - Multiple exclude list per tarsnap WWW: https://github.com/danrue/feather Feature safe: yes
Notes
Notes: svn path=/head/; revision=286705
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/feather/Makefile49
-rw-r--r--sysutils/feather/distinfo2
-rw-r--r--sysutils/feather/files/pkg-message.in11
-rw-r--r--sysutils/feather/pkg-descr12
-rw-r--r--sysutils/feather/pkg-plist4
6 files changed, 79 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index dc52ccae72fa..b798c8432e1f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -220,6 +220,7 @@
SUBDIR += fconfig
SUBDIR += fcron
SUBDIR += fdupes
+ SUBDIR += feather
SUBDIR += fetchlog
SUBDIR += ffs2recov
SUBDIR += file
diff --git a/sysutils/feather/Makefile b/sysutils/feather/Makefile
new file mode 100644
index 000000000000..c9c06c0959d9
--- /dev/null
+++ b/sysutils/feather/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: feather
+# Date created: 2011-11-30
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= feather
+PORTVERSION= 1.0
+CATEGORIES= sysutils python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A Python script for managing tarsnap backups
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml \
+ tarsnap>=0:${PORTSDIR}/sysutils/tarsnap
+
+USE_PYTHON= 2.5+
+NO_BUILD= yes
+NO_INSTALL= yes
+STRIP=
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/feather ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/feather.yaml.dist ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+x-generate-tarball:
+ ${SETENV} ${FETCH_ENV} ${FETCH_BINARY} -m -o ${PORTNAME}.tar.gz \
+ https://github.com/danrue/${PORTNAME}/tarball/master
+ target=`${TAR} -tvf ${PORTNAME}.tar.gz | head -n 1`; \
+ dir=`${ECHO} $${target} | ${AWK} '{print $$9}' | ${SED} -e 's|/$$||'`; \
+ ${TAR} -zxf ${PORTNAME}.tar.gz; \
+ ${RM} ${PORTNAME}.tar.gz; \
+ ${MV} $${dir} ${PORTNAME}-${PORTVERSION}; \
+ ${TAR} -zcf ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-${PORTVERSION}; \
+ ${RM} -r ${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/sysutils/feather/distinfo b/sysutils/feather/distinfo
new file mode 100644
index 000000000000..bbfe4c8fd495
--- /dev/null
+++ b/sysutils/feather/distinfo
@@ -0,0 +1,2 @@
+SHA256 (feather-1.0.tar.gz) = a787bb73baa4377a375412c1882fd6f04c3f88a23b474fef4988b53dedef24a2
+SIZE (feather-1.0.tar.gz) = 4992
diff --git a/sysutils/feather/files/pkg-message.in b/sysutils/feather/files/pkg-message.in
new file mode 100644
index 000000000000..9e9639f9cfc2
--- /dev/null
+++ b/sysutils/feather/files/pkg-message.in
@@ -0,0 +1,11 @@
+*****************************************************************
+
+Feather is designed to be run from cron like this:
+
+ */5 * * * * %%PREFIX%%/bin/feather %%PREFIX%%/etc/feather.yaml
+
+If installed, please check the contents of %%DOCSDIR%%/README
+for the syntax of the YAML file, as well as the sample file at
+%%PREFIX%%/etc/feather.yaml.dist.
+
+*****************************************************************
diff --git a/sysutils/feather/pkg-descr b/sysutils/feather/pkg-descr
new file mode 100644
index 000000000000..24bfe6588b96
--- /dev/null
+++ b/sysutils/feather/pkg-descr
@@ -0,0 +1,12 @@
+Feather is a tarsnap wrapper script that performs and maintains a
+set of backups as defined by a YAML configuration file.
+
+Features:
+ - Dynamic scheduling
+ - Keep an arbitrary number of backups of each schedule type
+ - Restrict schedules based on time of day
+ - Restrict feather run to a certain amount of wall time (max_runtime)
+ - Multiple backup paths per tarsnap
+ - Multiple exclude list per tarsnap
+
+WWW: https://github.com/danrue/feather
diff --git a/sysutils/feather/pkg-plist b/sysutils/feather/pkg-plist
new file mode 100644
index 000000000000..3ecef9e867bb
--- /dev/null
+++ b/sysutils/feather/pkg-plist
@@ -0,0 +1,4 @@
+bin/feather
+etc/feather.yaml.dist
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%