aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:43:06 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:43:06 +0000
commit70bf188dc59e40d6c62f5b65db7c1fdc12bf2504 (patch)
tree52144c3c50b5e14cca29ed31cafaba4e278b746d /sysutils
parent31aa31cccc3a73c6e83a04087cdde6b6b87158b8 (diff)
downloadports-70bf188dc59e40d6c62f5b65db7c1fdc12bf2504.tar.gz
ports-70bf188dc59e40d6c62f5b65db7c1fdc12bf2504.zip
A tool for starting up the Etoile project in the correct order.
Notes
Notes: svn path=/head/; revision=180589
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/etoile-system/Makefile37
-rw-r--r--sysutils/etoile-system/distinfo3
-rw-r--r--sysutils/etoile-system/pkg-descr3
-rw-r--r--sysutils/etoile-system/pkg-plist8
5 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index eef5692e19d7..7c9a619b83d7 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -164,6 +164,7 @@
SUBDIR += etcmerge
SUBDIR += etoile-behavior
SUBDIR += etoile-installer
+ SUBDIR += etoile-system
SUBDIR += eventlog
SUBDIR += eventwatcher
SUBDIR += evtviewer
diff --git a/sysutils/etoile-system/Makefile b/sysutils/etoile-system/Makefile
new file mode 100644
index 000000000000..df9968e9a6e1
--- /dev/null
+++ b/sysutils/etoile-system/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: etoile-system
+# Date created: 19 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= system
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project System Tool
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Services/Private/System
+
+post-install:
+ ${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Etoile
+ ${CP} ${WRKSRC}/Services/Private/System/SystemTaskList.plist \
+ ${GNUSTEP_PREFIX}/System/Library/Etoile/
+
+.include <bsd.port.mk>
diff --git a/sysutils/etoile-system/distinfo b/sysutils/etoile-system/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/sysutils/etoile-system/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/sysutils/etoile-system/pkg-descr b/sysutils/etoile-system/pkg-descr
new file mode 100644
index 000000000000..f67910c8fb04
--- /dev/null
+++ b/sysutils/etoile-system/pkg-descr
@@ -0,0 +1,3 @@
+A tool for starting up the Etoile project in the correct order.
+
+WWW: http://www.etoile-project.org/
diff --git a/sysutils/etoile-system/pkg-plist b/sysutils/etoile-system/pkg-plist
new file mode 100644
index 000000000000..6adcbd26f80b
--- /dev/null
+++ b/sysutils/etoile-system/pkg-plist
@@ -0,0 +1,8 @@
+System/Library/Etoile/SystemTaskList.plist
+System/Library/Headers/WorkspaceCommKit/NSWorkspace+Communication.h
+System/Library/Libraries/libWorkspaceCommKit.so
+System/Library/Libraries/libWorkspaceCommKit.so.%%MAJORLIBVERSION%%
+System/Library/Libraries/libWorkspaceCommKit.so.%%LIBVERSION%%
+System/Tools/etoile_system
+@dirrm System/Library/Headers/WorkspaceCommKit
+@dirrm System/Library/Etoile