aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-10-10 13:44:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-10-10 13:44:01 +0000
commit7a5798722444996286021172e5c5217606ca6292 (patch)
treedf348ef07cf6952b6a8fd0c0c75dfc0a61ed3143 /sysutils
parent0942aa369474617d1736b01c8022746d494c2f07 (diff)
downloadports-7a5798722444996286021172e5c5217606ca6292.tar.gz
ports-7a5798722444996286021172e5c5217606ca6292.zip
GNOME system monitor.
PR: ports/8228 Submitted by: Yukihiro Nakai <nakai@technologist.com>
Notes
Notes: svn path=/head/; revision=13855
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gnome-system-monitor/Makefile32
-rw-r--r--sysutils/gnome-system-monitor/distinfo1
-rw-r--r--sysutils/gnome-system-monitor/pkg-comment1
-rw-r--r--sysutils/gnome-system-monitor/pkg-descr1
-rw-r--r--sysutils/gnome-system-monitor/pkg-plist11
-rw-r--r--sysutils/gnomesystemmonitor/Makefile32
-rw-r--r--sysutils/gnomesystemmonitor/distinfo1
-rw-r--r--sysutils/gnomesystemmonitor/pkg-comment1
-rw-r--r--sysutils/gnomesystemmonitor/pkg-descr1
-rw-r--r--sysutils/gnomesystemmonitor/pkg-plist11
-rw-r--r--sysutils/gtop/Makefile32
-rw-r--r--sysutils/gtop/distinfo1
-rw-r--r--sysutils/gtop/pkg-comment1
-rw-r--r--sysutils/gtop/pkg-descr1
-rw-r--r--sysutils/gtop/pkg-plist11
15 files changed, 138 insertions, 0 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
new file mode 100644
index 000000000000..cf68ac4b995c
--- /dev/null
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtop
+# Version required: 0.28.1
+# Date created: 28 September 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= gtop-0.28.1
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.home-of-linux.org/pub/gtop/0.28.1/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs \
+ gtop.0:${PORTSDIR}/devel/libgtop
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ chowm root.kmem ${PREFIX}/bin/gtop
+ chmod 2555 ${PREFIX}/bin/gtop
+
+.include <bsd.port.mk>
diff --git a/sysutils/gnome-system-monitor/distinfo b/sysutils/gnome-system-monitor/distinfo
new file mode 100644
index 000000000000..45ea256d8f24
--- /dev/null
+++ b/sysutils/gnome-system-monitor/distinfo
@@ -0,0 +1 @@
+MD5 (gtop-0.28.1.tar.gz) = 86366851eb08791d6259506bae236c62
diff --git a/sysutils/gnome-system-monitor/pkg-comment b/sysutils/gnome-system-monitor/pkg-comment
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gnome-system-monitor/pkg-comment
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gnome-system-monitor/pkg-descr b/sysutils/gnome-system-monitor/pkg-descr
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gnome-system-monitor/pkg-descr
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gnome-system-monitor/pkg-plist b/sysutils/gnome-system-monitor/pkg-plist
new file mode 100644
index 000000000000..c5b3e9b6e7d1
--- /dev/null
+++ b/sysutils/gnome-system-monitor/pkg-plist
@@ -0,0 +1,11 @@
+bin/gtop
+share/gnome/gtoprc
+share/locale/cs/LC_MESSAGES/gtop.mo
+share/locale/de/LC_MESSAGES/gtop.mo
+share/locale/es/LC_MESSAGES/gtop.mo
+share/locale/fr/LC_MESSAGES/gtop.mo
+share/locale/ga/LC_MESSAGES/gtop.mo
+share/locale/it/LC_MESSAGES/gtop.mo
+share/locale/ko/LC_MESSAGES/gtop.mo
+share/locale/no/LC_MESSAGES/gtop.mo
+share/locale/pt/LC_MESSAGES/gtop.mo
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
new file mode 100644
index 000000000000..cf68ac4b995c
--- /dev/null
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtop
+# Version required: 0.28.1
+# Date created: 28 September 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= gtop-0.28.1
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.home-of-linux.org/pub/gtop/0.28.1/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs \
+ gtop.0:${PORTSDIR}/devel/libgtop
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ chowm root.kmem ${PREFIX}/bin/gtop
+ chmod 2555 ${PREFIX}/bin/gtop
+
+.include <bsd.port.mk>
diff --git a/sysutils/gnomesystemmonitor/distinfo b/sysutils/gnomesystemmonitor/distinfo
new file mode 100644
index 000000000000..45ea256d8f24
--- /dev/null
+++ b/sysutils/gnomesystemmonitor/distinfo
@@ -0,0 +1 @@
+MD5 (gtop-0.28.1.tar.gz) = 86366851eb08791d6259506bae236c62
diff --git a/sysutils/gnomesystemmonitor/pkg-comment b/sysutils/gnomesystemmonitor/pkg-comment
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gnomesystemmonitor/pkg-comment
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gnomesystemmonitor/pkg-descr b/sysutils/gnomesystemmonitor/pkg-descr
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gnomesystemmonitor/pkg-descr
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gnomesystemmonitor/pkg-plist b/sysutils/gnomesystemmonitor/pkg-plist
new file mode 100644
index 000000000000..c5b3e9b6e7d1
--- /dev/null
+++ b/sysutils/gnomesystemmonitor/pkg-plist
@@ -0,0 +1,11 @@
+bin/gtop
+share/gnome/gtoprc
+share/locale/cs/LC_MESSAGES/gtop.mo
+share/locale/de/LC_MESSAGES/gtop.mo
+share/locale/es/LC_MESSAGES/gtop.mo
+share/locale/fr/LC_MESSAGES/gtop.mo
+share/locale/ga/LC_MESSAGES/gtop.mo
+share/locale/it/LC_MESSAGES/gtop.mo
+share/locale/ko/LC_MESSAGES/gtop.mo
+share/locale/no/LC_MESSAGES/gtop.mo
+share/locale/pt/LC_MESSAGES/gtop.mo
diff --git a/sysutils/gtop/Makefile b/sysutils/gtop/Makefile
new file mode 100644
index 000000000000..cf68ac4b995c
--- /dev/null
+++ b/sysutils/gtop/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtop
+# Version required: 0.28.1
+# Date created: 28 September 1998
+# Whom: Yukihiro Nakai <Nakai@technologist.com>
+#
+# $Id$
+#
+
+DISTNAME= gtop-0.28.1
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.home-of-linux.org/pub/gtop/0.28.1/
+
+MAINTAINER= Nakai@technologist.com
+
+LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs \
+ gtop.0:${PORTSDIR}/devel/libgtop
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ chowm root.kmem ${PREFIX}/bin/gtop
+ chmod 2555 ${PREFIX}/bin/gtop
+
+.include <bsd.port.mk>
diff --git a/sysutils/gtop/distinfo b/sysutils/gtop/distinfo
new file mode 100644
index 000000000000..45ea256d8f24
--- /dev/null
+++ b/sysutils/gtop/distinfo
@@ -0,0 +1 @@
+MD5 (gtop-0.28.1.tar.gz) = 86366851eb08791d6259506bae236c62
diff --git a/sysutils/gtop/pkg-comment b/sysutils/gtop/pkg-comment
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gtop/pkg-comment
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gtop/pkg-descr b/sysutils/gtop/pkg-descr
new file mode 100644
index 000000000000..f08d391b296f
--- /dev/null
+++ b/sysutils/gtop/pkg-descr
@@ -0,0 +1 @@
+GNOME system moniter program
diff --git a/sysutils/gtop/pkg-plist b/sysutils/gtop/pkg-plist
new file mode 100644
index 000000000000..c5b3e9b6e7d1
--- /dev/null
+++ b/sysutils/gtop/pkg-plist
@@ -0,0 +1,11 @@
+bin/gtop
+share/gnome/gtoprc
+share/locale/cs/LC_MESSAGES/gtop.mo
+share/locale/de/LC_MESSAGES/gtop.mo
+share/locale/es/LC_MESSAGES/gtop.mo
+share/locale/fr/LC_MESSAGES/gtop.mo
+share/locale/ga/LC_MESSAGES/gtop.mo
+share/locale/it/LC_MESSAGES/gtop.mo
+share/locale/ko/LC_MESSAGES/gtop.mo
+share/locale/no/LC_MESSAGES/gtop.mo
+share/locale/pt/LC_MESSAGES/gtop.mo