aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-21 00:57:42 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-21 00:57:42 +0000
commit2646e845ff93d66d7a8b1135ca481e9f284af0c8 (patch)
treedeffabe320b2949ec66c44c67f9ddb3ce9279bca /sysutils
parentf28b472edc2b1b9ab1b8f9c6c525fa3f8fdb90f4 (diff)
downloadports-2646e845ff93d66d7a8b1135ca481e9f284af0c8.tar.gz
ports-2646e845ff93d66d7a8b1135ca481e9f284af0c8.zip
Move manpages from pkg/PLIST to Makefile.
Notes
Notes: svn path=/head/; revision=14135
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/LPRng/Makefile9
-rw-r--r--sysutils/LPRng/pkg-plist18
-rw-r--r--sysutils/contool/Makefile4
-rw-r--r--sysutils/contool/pkg-plist1
-rw-r--r--sysutils/manck/Makefile5
-rw-r--r--sysutils/manck/pkg-plist1
-rw-r--r--sysutils/setquota/Makefile5
-rw-r--r--sysutils/setquota/pkg-plist2
-rw-r--r--sysutils/skill/Makefile6
-rw-r--r--sysutils/skill/pkg-plist1
-rw-r--r--sysutils/stat/Makefile5
-rw-r--r--sysutils/stat/pkg-plist1
-rw-r--r--sysutils/xcpustate/Makefile4
-rw-r--r--sysutils/xcpustate/pkg-plist1
-rw-r--r--sysutils/xdu/Makefile3
-rw-r--r--sysutils/xdu/pkg-plist1
-rw-r--r--sysutils/xfsm/Makefile3
-rw-r--r--sysutils/xfsm/pkg-plist1
-rw-r--r--sysutils/xloadface/Makefile4
-rw-r--r--sysutils/xloadface/pkg-plist5
-rw-r--r--sysutils/xperfmon/Makefile3
-rw-r--r--sysutils/xperfmon/pkg-plist1
-rw-r--r--sysutils/xperfmon3/Makefile3
-rw-r--r--sysutils/xperfmon3/pkg-plist1
-rw-r--r--sysutils/xsysstats/Makefile3
-rw-r--r--sysutils/xsysstats/pkg-plist1
26 files changed, 45 insertions, 47 deletions
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index ab95ad600964..6d717e6a4675 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -3,7 +3,7 @@
# Date created: 2 Apr 1997
# Whom: desmo@bandwidth.org
#
-# $Id: Makefile,v 1.3 1998/01/22 08:19:36 fenner Exp $
+# $Id: Makefile,v 1.4 1998/06/04 23:59:08 steve Exp $
#
DISTNAME= LPRng-3.5.1
@@ -20,6 +20,13 @@ MAKEFILE= Makefile.bsd
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-lpddir=/usr/local/sbin
+MAN1= authenticate_pgp.1 cancel.1 lp.1 lpbanner.1 lpc.1 lpf.1 \
+ lpq.1 lpr.1 lpraccnt.1 lprm.1 lpstat.1 monitor.1 \
+ readfilecount.1
+MAN5= lpd.conf.5 lpd.perms.5 printcap.5
+MAN8= checkpc.8 lpd.8
+MANCOMPRESSED= yes
+
post-install:
(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} default)
@cat ${FILESDIR}/lprng.sh | \
diff --git a/sysutils/LPRng/pkg-plist b/sysutils/LPRng/pkg-plist
index def6837c02bd..7e5d19c09150 100644
--- a/sysutils/LPRng/pkg-plist
+++ b/sysutils/LPRng/pkg-plist
@@ -11,24 +11,6 @@ sbin/readfilecount
sbin/removeoneline
sbin/authenticate_pgp
sbin/setupauth
-man/man1/authenticate_pgp.1.gz
-man/man1/cancel.1.gz
-man/man1/lp.1.gz
-man/man1/lpbanner.1.gz
-man/man1/lpc.1.gz
-man/man1/lpf.1.gz
-man/man1/lpq.1.gz
-man/man1/lpr.1.gz
-man/man1/lpraccnt.1.gz
-man/man1/lprm.1.gz
-man/man1/lpstat.1.gz
-man/man1/monitor.1.gz
-man/man1/readfilecount.1.gz
-man/man5/lpd.conf.5.gz
-man/man5/lpd.perms.5.gz
-man/man5/printcap.5.gz
-man/man8/checkpc.8.gz
-man/man8/lpd.8.gz
share/doc/LPRng/LPRng_DOC-3.5.1/Tutorial.ps
share/doc/LPRng/LPRng_DOC-3.5.1/Makefile
share/doc/LPRng/LPRng_DOC-3.5.1/Tutorial/Tutorial.02.nrf
diff --git a/sysutils/contool/Makefile b/sysutils/contool/Makefile
index 510c1eb73928..3034c26a2584 100644
--- a/sysutils/contool/Makefile
+++ b/sysutils/contool/Makefile
@@ -3,7 +3,7 @@
# Date created: 2 Dec 1996
# Whom: nsayer@quack.kfu.com
#
-# $Id: Makefile,v 1.5 1998/08/07 23:56:47 asami Exp $
+# $Id: Makefile,v 1.6 1998/09/21 22:15:58 steve Exp $
#
DISTNAME= contool-3.3a
@@ -18,6 +18,8 @@ NO_CDROM= "source code cannot be sold, nor can you incorporate the source code i
NO_WRKSUBDIR= yes
USE_IMAKE= yes
+MAN1= contool.1
+
pre-install:
@${MKDIR} ${PREFIX}/lib/help
diff --git a/sysutils/contool/pkg-plist b/sysutils/contool/pkg-plist
index 66a17395aae4..1d3780e924b3 100644
--- a/sysutils/contool/pkg-plist
+++ b/sysutils/contool/pkg-plist
@@ -1,3 +1,2 @@
bin/contool
lib/help/contool.info
-man/man1/contool.1.gz
diff --git a/sysutils/manck/Makefile b/sysutils/manck/Makefile
index 59a8c7598a7e..bc1804dba71e 100644
--- a/sysutils/manck/Makefile
+++ b/sysutils/manck/Makefile
@@ -3,7 +3,7 @@
# Date created: 10 September 1995
# Whom: joerg
#
-# $Id: Makefile,v 1.8 1997/08/09 00:26:26 wosch Exp $
+# $Id: Makefile,v 1.9 1997/08/16 10:14:49 wosch Exp $
#
DISTNAME= manck-1.2
@@ -12,4 +12,7 @@ MASTER_SITES= http://www.freebsd.org/~wosch/src/
MAINTAINER= wosch@FreeBSD.org
+MAN1= manck.1
+MANCOMPRESSED= yes
+
.include <bsd.port.mk>
diff --git a/sysutils/manck/pkg-plist b/sysutils/manck/pkg-plist
index 57621dc32477..3a7f7d28a03d 100644
--- a/sysutils/manck/pkg-plist
+++ b/sysutils/manck/pkg-plist
@@ -1,2 +1 @@
bin/manck
-man/man1/manck.1.gz
diff --git a/sysutils/setquota/Makefile b/sysutils/setquota/Makefile
index 571d8c830d4f..b01baf51dfa4 100644
--- a/sysutils/setquota/Makefile
+++ b/sysutils/setquota/Makefile
@@ -3,7 +3,7 @@
# Date created: 27 September 1997
# Whom: winter@jurai.net
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/09/27 22:34:20 joerg Exp $
#
DISTNAME= setquota-0.1
@@ -14,4 +14,7 @@ MAINTAINER= winter@jurai.net
WRKSRC= ${WRKDIR}/setquota/
+MAN8= getquota.8 setquota.8
+MANCOMPRESSED= yes
+
.include <bsd.port.mk>
diff --git a/sysutils/setquota/pkg-plist b/sysutils/setquota/pkg-plist
index 83afcbae3a80..b97a3fdb539b 100644
--- a/sysutils/setquota/pkg-plist
+++ b/sysutils/setquota/pkg-plist
@@ -1,4 +1,2 @@
sbin/setquota
sbin/getquota
-man/man8/setquota.8.gz
-man/man8/getquota.8.gz
diff --git a/sysutils/skill/Makefile b/sysutils/skill/Makefile
index 5a86e688691d..48bd40b40c61 100644
--- a/sysutils/skill/Makefile
+++ b/sysutils/skill/Makefile
@@ -3,7 +3,7 @@
# Date created: 04 Jun 1997
# Whom: Joao Carlos Mendes Luis <jonny@mailhost.coppe.ufrj.br>
#
-# $Id: Makefile,v 1.1.1.1 1997/06/05 17:03:24 obrien Exp $
+# $Id: Makefile,v 1.2 1997/10/30 02:30:10 jseger Exp $
#
DISTNAME= skill-3.7@P4
@@ -19,6 +19,7 @@ CONFIGURE_SCRIPT= Config
WRKSRC= ${WRKDIR}/${PKGNAME}
MAN1= skill.1
+MLINKS= skill.1 snice.1
# Bugs: skill.1 and snice.1 are hard links. When compressed they
# are changed to independent files. I'd like to change this...
@@ -26,7 +27,4 @@ MAN1= skill.1
pre-configure:
@chmod a+x ${WRKSRC}/Config
-post-install:
- @ln -sf ${PREFIX}/man/man1/skill.1.gz ${PREFIX}/man/man1/snice.1.gz
-
.include <bsd.port.mk>
diff --git a/sysutils/skill/pkg-plist b/sysutils/skill/pkg-plist
index 865472e5c6a4..44d0826db364 100644
--- a/sysutils/skill/pkg-plist
+++ b/sysutils/skill/pkg-plist
@@ -1,3 +1,2 @@
bin/skill
bin/snice
-man/man1/snice.1.gz
diff --git a/sysutils/stat/Makefile b/sysutils/stat/Makefile
index cdc78af74609..718c68ddfa18 100644
--- a/sysutils/stat/Makefile
+++ b/sysutils/stat/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 Februar 1996
# Whom: wosch
#
-# $Id: Makefile,v 1.3 1997/08/09 00:28:49 wosch Exp $
+# $Id: Makefile,v 1.4 1997/08/21 22:58:18 wosch Exp $
DISTNAME= stat-1.3
CATEGORIES= sysutils
@@ -11,4 +11,7 @@ MASTER_SITES= http://www.freebsd.org/~wosch/src/
MAINTAINER= wosch@FreeBSD.org
+MAN1= stat.1
+MANCOMPRESSED= yes
+
.include <bsd.port.mk>
diff --git a/sysutils/stat/pkg-plist b/sysutils/stat/pkg-plist
index 54d7995ad085..29ead85a5633 100644
--- a/sysutils/stat/pkg-plist
+++ b/sysutils/stat/pkg-plist
@@ -1,2 +1 @@
bin/stat
-man/man1/stat.1.gz
diff --git a/sysutils/xcpustate/Makefile b/sysutils/xcpustate/Makefile
index a06b0c75de18..84350a80398c 100644
--- a/sysutils/xcpustate/Makefile
+++ b/sysutils/xcpustate/Makefile
@@ -4,7 +4,7 @@
# Date created: 31-Dec-1995
# Whom: David O'Brien <obrien@cs.ucdavis.edu>
#
-# $Id: Makefile,v 1.10 1998/02/01 22:49:26 fenner Exp $
+# $Id: Makefile,v 1.11 1998/03/06 01:58:14 obrien Exp $
#
DISTNAME= xcpustate-2.5
@@ -22,4 +22,6 @@ EXTRACT_AFTER_ARGS= |sh
USE_IMAKE= yes
NO_WRKSUBDIR= yes
+MAN1= xcpustate.1
+
.include <bsd.port.mk>
diff --git a/sysutils/xcpustate/pkg-plist b/sysutils/xcpustate/pkg-plist
index 7d09fdeeb440..8e2a0b1e1c83 100644
--- a/sysutils/xcpustate/pkg-plist
+++ b/sysutils/xcpustate/pkg-plist
@@ -1,2 +1 @@
bin/xcpustate
-man/man1/xcpustate.1.gz
diff --git a/sysutils/xdu/Makefile b/sysutils/xdu/Makefile
index b7cb5d5d7922..e2bfce059c00 100644
--- a/sysutils/xdu/Makefile
+++ b/sysutils/xdu/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 February 1995
# Whom: asami
#
-# $Id: Makefile,v 1.6 1996/11/17 08:06:39 obrien Exp $
+# $Id: Makefile,v 1.7 1997/12/25 22:29:45 asami Exp $
#
DISTNAME= xdu-3.0
@@ -15,5 +15,6 @@ MAINTAINER= ports@FreeBSD.ORG
NO_WRKSUBDIR= yes
USE_IMAKE= yes
+MAN1= xdu.1
.include <bsd.port.mk>
diff --git a/sysutils/xdu/pkg-plist b/sysutils/xdu/pkg-plist
index 674af7ad3303..d64680332bbb 100644
--- a/sysutils/xdu/pkg-plist
+++ b/sysutils/xdu/pkg-plist
@@ -1,3 +1,2 @@
bin/xdu
lib/X11/app-defaults/XDu
-man/man1/xdu.1.gz
diff --git a/sysutils/xfsm/Makefile b/sysutils/xfsm/Makefile
index 36b8fe83d723..647e6c4c2cfc 100644
--- a/sysutils/xfsm/Makefile
+++ b/sysutils/xfsm/Makefile
@@ -3,7 +3,7 @@
# Date Created: 24 Nov 1997
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.2 1998/01/19 13:34:44 vanilla Exp $
+# $Id: Makefile,v 1.3 1998/06/04 03:49:27 vanilla Exp $
#
DISTNAME= xfsm-1.97
@@ -14,5 +14,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= vanilla@FreeBSD.ORG
USE_IMAKE= yes
+MAN1= xfsm.1
.include <bsd.port.mk>
diff --git a/sysutils/xfsm/pkg-plist b/sysutils/xfsm/pkg-plist
index 46df1fda995a..be4382dd5b0d 100644
--- a/sysutils/xfsm/pkg-plist
+++ b/sysutils/xfsm/pkg-plist
@@ -1,2 +1 @@
bin/xfsm
-man/man1/xfsm.1.gz
diff --git a/sysutils/xloadface/Makefile b/sysutils/xloadface/Makefile
index 7d7a05ad1a6d..be3623712f2d 100644
--- a/sysutils/xloadface/Makefile
+++ b/sysutils/xloadface/Makefile
@@ -3,7 +3,7 @@
# Date created: 4 February 1998
# Whom: FURUSAWA,Kazuhisa <kazu@jp.freebsd.org>
#
-# $Id: Makefile,v 1.1.1.1 1996/12/04 02:04:57 obrien Exp $
+# $Id: Makefile,v 1.2 1998/02/07 19:53:25 fenner Exp $
#
DISTNAME= xloadface-1.6.1
@@ -18,6 +18,8 @@ PATCH_STRIP= -p1
USE_IMAKE= yes
XLOADFACEDIR= $(X11BASE)/lib/X11/xloadface
+MAN1= xloadface.1
+
pre-install:
@nkf -e ${WRKSRC}/xloadface.1 > ${WRKSRC}/xloadface.man
${MKDIR} $(XLOADFACEDIR)
diff --git a/sysutils/xloadface/pkg-plist b/sysutils/xloadface/pkg-plist
index f9f203de272f..73a594961048 100644
--- a/sysutils/xloadface/pkg-plist
+++ b/sysutils/xloadface/pkg-plist
@@ -1,5 +1,4 @@
bin/xloadface
-man/man1/xloadface.1.gz
lib/X11/xloadface/README
lib/X11/xloadface/host_org.sample
lib/X11/xloadface/bigfaces/busy.icon
@@ -24,3 +23,7 @@ lib/X11/xloadface/catfaces/fever.icon
lib/X11/xloadface/catfaces/heavy.icon
lib/X11/xloadface/catfaces/idle.icon
lib/X11/xloadface/catfaces/run.icon
+@dirrm lib/X11/xloadface/bigfaces
+@dirrm lib/X11/xloadface/bitmap
+@dirrm lib/X11/xloadface/catfaces
+@dirrm lib/X11/xloadface
diff --git a/sysutils/xperfmon/Makefile b/sysutils/xperfmon/Makefile
index 339847d536e2..5240bd731d48 100644
--- a/sysutils/xperfmon/Makefile
+++ b/sysutils/xperfmon/Makefile
@@ -3,7 +3,7 @@
# Date created: 14 March 97
# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
#
-# $Id: Makefile,v 1.17 1998/09/30 19:32:35 gj Exp $
+# $Id: Makefile,v 1.18 1998/10/09 10:01:32 obrien Exp $
#
DISTNAME= xperfmon++
@@ -18,6 +18,7 @@ DISTFILES= xperfmon++v1.1.tar.Z
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
USE_IMAKE= yes
+MAN1= xperfmon++.1
pre-configure:
if [ -e /usr/lib/libdevstat.a -o -e /usr/lib/aout/libdevstat.a ]; then \
diff --git a/sysutils/xperfmon/pkg-plist b/sysutils/xperfmon/pkg-plist
index 4951b8811d23..4fc9fe3d29c0 100644
--- a/sysutils/xperfmon/pkg-plist
+++ b/sysutils/xperfmon/pkg-plist
@@ -1,3 +1,2 @@
bin/xperfmon++
lib/X11/app-defaults/XPerfmon++
-man/man1/xperfmon++.1.gz
diff --git a/sysutils/xperfmon3/Makefile b/sysutils/xperfmon3/Makefile
index 339847d536e2..5240bd731d48 100644
--- a/sysutils/xperfmon3/Makefile
+++ b/sysutils/xperfmon3/Makefile
@@ -3,7 +3,7 @@
# Date created: 14 March 97
# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.DE>
#
-# $Id: Makefile,v 1.17 1998/09/30 19:32:35 gj Exp $
+# $Id: Makefile,v 1.18 1998/10/09 10:01:32 obrien Exp $
#
DISTNAME= xperfmon++
@@ -18,6 +18,7 @@ DISTFILES= xperfmon++v1.1.tar.Z
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
USE_IMAKE= yes
+MAN1= xperfmon++.1
pre-configure:
if [ -e /usr/lib/libdevstat.a -o -e /usr/lib/aout/libdevstat.a ]; then \
diff --git a/sysutils/xperfmon3/pkg-plist b/sysutils/xperfmon3/pkg-plist
index 4951b8811d23..4fc9fe3d29c0 100644
--- a/sysutils/xperfmon3/pkg-plist
+++ b/sysutils/xperfmon3/pkg-plist
@@ -1,3 +1,2 @@
bin/xperfmon++
lib/X11/app-defaults/XPerfmon++
-man/man1/xperfmon++.1.gz
diff --git a/sysutils/xsysstats/Makefile b/sysutils/xsysstats/Makefile
index 4c6f0adbb607..f7630baa0aae 100644
--- a/sysutils/xsysstats/Makefile
+++ b/sysutils/xsysstats/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 December 1994
# Whom: asami
#
-# $Id: Makefile,v 1.10 1997/12/25 22:29:46 asami Exp $
+# $Id: Makefile,v 1.11 1998/01/09 10:15:46 obrien Exp $
#
DISTNAME= xsysstats1.34
@@ -15,5 +15,6 @@ MASTER_SITE_SUBDIR= utilities
MAINTAINER= obrien@FreeBSD.ORG
USE_IMAKE= yes
+MAN1= xsysstats.1
.include <bsd.port.mk>
diff --git a/sysutils/xsysstats/pkg-plist b/sysutils/xsysstats/pkg-plist
index 553fec460d3b..2eb7a8e350f4 100644
--- a/sysutils/xsysstats/pkg-plist
+++ b/sysutils/xsysstats/pkg-plist
@@ -1,2 +1 @@
bin/xsysstats
-man/man1/xsysstats.1.gz