aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-03-12 05:17:42 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-03-12 05:17:42 +0000
commit63180e3a249bd2e2b5dc54b48eeaee568c24176c (patch)
treecbead011e7018da46cf868012de1acf2837de4e8 /sysutils
parentea387de62be0c846c4fce2e9e8fd873a602b1db6 (diff)
downloadports-63180e3a249bd2e2b5dc54b48eeaee568c24176c.tar.gz
ports-63180e3a249bd2e2b5dc54b48eeaee568c24176c.zip
- drop unknown post-deinstall target and move into SUB_FILES
- bump PORTREVISION accordingly PR: ports/164341 Submitted by: jgh@ Approved by: maintainer timeout ( 51 days ) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293150
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/graid5/Makefile6
-rw-r--r--sysutils/graid5/files/pkg-deinstall.in5
2 files changed, 8 insertions, 3 deletions
diff --git a/sysutils/graid5/Makefile b/sysutils/graid5/Makefile
index 86baf4dace16..11392168d6e2 100644
--- a/sysutils/graid5/Makefile
+++ b/sysutils/graid5/Makefile
@@ -7,6 +7,7 @@
PORTNAME= graid5
PORTVERSION= ${MAINVERSION}.${VERSIONDATE}
+PORTREVISION= 1
CATEGORIES= sysutils kld
MASTER_SITES= http://lev.serebryakov.spb.ru/download/graid5/
@@ -22,6 +23,8 @@ VERSIONDATE=20110927.40
KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR:C,^/,,}
+SUB_LIST= KMODDIR=${KMODDIR}
+SUB_FILES= pkg-deinstall
MAKE_ENV+= KMODDIR=${KMODDIR}
MANCOMPRESSED= yes
@@ -36,7 +39,4 @@ IGNORE= requires sbin source files
post-install:
kldxref ${KMODDIR}
-post-deinstall:
- kldxref ${KMODDIR}
-
.include <bsd.port.mk>
diff --git a/sysutils/graid5/files/pkg-deinstall.in b/sysutils/graid5/files/pkg-deinstall.in
new file mode 100644
index 000000000000..5de13d7c3787
--- /dev/null
+++ b/sysutils/graid5/files/pkg-deinstall.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ /usr/sbin/kldxref %%KMODDIR%%
+fi