aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 03:30:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 03:30:31 +0000
commit4f13830aad19fce51bc3ce4c7f586549106e5ef4 (patch)
treef2e85c124664e0dd7254f322c3fa18a30d9b1ed3 /sysutils
parent52573d4e578e2e0bae9500f401ef3872ec0c7de4 (diff)
downloadports-4f13830aad19fce51bc3ce4c7f586549106e5ef4.tar.gz
ports-4f13830aad19fce51bc3ce4c7f586549106e5ef4.zip
- Fix X11 libraries dependency handling: this is a better fix to ports/153198
- Add OPTIONS X11: build pwsafe with X11 libraries (default off) - Bump PORTREVISION for dependency change - Cosmetic change PR: ports/162649 Reported by: Jeremie Le Hen <jeremie@le-hen.org> Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 16 days) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286899
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pwsafe/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/sysutils/pwsafe/Makefile b/sysutils/pwsafe/Makefile
index 65e23f85c632..73dd12cf761b 100644
--- a/sysutils/pwsafe/Makefile
+++ b/sysutils/pwsafe/Makefile
@@ -7,30 +7,39 @@
PORTNAME= pwsafe
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://nsd.dyndns.org/pwsafe/releases/
MAINTAINER= donnex@donnex.net
COMMENT= Cmdline program that manages encrypted password databases
-OPTIONS= SETUID "Install setuid pwsafe binary" off
+OPTIONS= SETUID "Install setuid pwsafe binary" off \
+ X11 "Build with X11 libraries" off
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_XORG= ice sm x11 xmu
MAN1= pwsafe.1
PLIST_FILES= bin/pwsafe
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if defined(WITH_X11)
+CONFIGURE_ARGS= --with-x
+USE_XORG= ice sm x11 xmu
+.else
+CONFIGURE_ARGS= ac_cv_have_x="have_x=no" \
+ ac_cv_lib_ICE_IceConnectionNumber=no \
+ ac_cv_lib_X11_XOpenDisplay=no \
+ ac_cv_lib_Xmu_XmuInternAtom=no
+.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pwsafe ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pwsafe.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/pwsafe ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/pwsafe.1 ${PREFIX}/man/man1/
.if defined(WITH_SETUID)
${CHMOD} u+s ${PREFIX}/bin/pwsafe
.endif
-.include <bsd.port.post.mk>
-
+.include <bsd.port.mk>