aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:34:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:34:37 +0000
commit9826257cefc37d1fa15c4d991b661882d275aa42 (patch)
treec73b717f1013e8ef76df53820edb639ec34c3cb6 /sysutils
parent549f83280cf5d75ddf7380c63683d79442ac0883 (diff)
downloadports-9826257cefc37d1fa15c4d991b661882d275aa42.tar.gz
ports-9826257cefc37d1fa15c4d991b661882d275aa42.zip
- Update to 2.0.19
PR: 162861 Submitted by: Alex Deiter <alex.deiter@gmail.com> (maintaner) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286482
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/openipmi/Makefile10
-rw-r--r--sysutils/openipmi/distinfo4
-rw-r--r--sysutils/openipmi/files/patch-configure.in10
-rw-r--r--sysutils/openipmi/files/patch-lib-sensor.c11
4 files changed, 19 insertions, 16 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index 1a31edbcdf75..c5387865ea0d 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= openipmi
-PORTVERSION= 2.0.18
-PORTREVISION= 5
+PORTVERSION= 2.0.19
CATEGORIES= sysutils
-MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library
DISTNAME= OpenIPMI-${PORTVERSION}
MAINTAINER= alex.deiter@gmail.com
@@ -39,6 +38,7 @@ OPTIONS= SSL "IPMI 2.0 RMCP+ encryption and authentication" On \
PYTHON "Python interface for OpenIPMI library" Off \
TCL "TCL interface for OpenIPMI library" Off \
TKINTER "GUI for OpenIPMI, written in Python" Off \
+ TRACE "Enable backtrace inspecting" Off \
GDBM "Local SDR caching on startup" Off \
GLIB12 "Simply OS handler for glib 1.2" Off \
GLIB20 "Simply OS handler for glib 2.0" Off
@@ -116,6 +116,10 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCL="@comment "
.endif
+.if defined(WITH_TRACE)
+LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
+.endif
+
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.endif
diff --git a/sysutils/openipmi/distinfo b/sysutils/openipmi/distinfo
index 8b8d5f086076..3b8b1821250f 100644
--- a/sysutils/openipmi/distinfo
+++ b/sysutils/openipmi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenIPMI-2.0.18.tar.gz) = 6c1679a1c16aade48dd929e5124d2640ff12224ac0de1bb3777e9f1030d62e01
-SIZE (OpenIPMI-2.0.18.tar.gz) = 2895686
+SHA256 (OpenIPMI-2.0.19.tar.gz) = 5b0de4741f07e350bf53b7d31bb20dd1109c2dc005dfb13969d8a9ff290f3a4e
+SIZE (OpenIPMI-2.0.19.tar.gz) = 2971041
diff --git a/sysutils/openipmi/files/patch-configure.in b/sysutils/openipmi/files/patch-configure.in
new file mode 100644
index 000000000000..538d354a9d11
--- /dev/null
+++ b/sysutils/openipmi/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig 2011-11-25 01:40:43.243119438 +0400
++++ configure.in 2011-11-25 01:42:18.859147897 +0400
+@@ -274,6 +274,7 @@
+ AC_CHECK_FUNCS(getaddrinfo)
+
+ AC_CHECK_HEADERS(execinfo.h)
++AC_SEARCH_LIBS(backtrace_symbols, [execinfo])
+
+ AC_SUBST(OPENIPMI_VERSION_MAJOR)
+ AC_SUBST(OPENIPMI_VERSION_MINOR)
diff --git a/sysutils/openipmi/files/patch-lib-sensor.c b/sysutils/openipmi/files/patch-lib-sensor.c
deleted file mode 100644
index 484f2baaddc4..000000000000
--- a/sysutils/openipmi/files/patch-lib-sensor.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/sensor.c.orig 2010-05-28 18:51:20.949496519 +0400
-+++ lib/sensor.c 2010-05-28 18:51:37.079705617 +0400
-@@ -1438,7 +1438,7 @@
- s[p]->id_type = IPMI_ASCII_STR;
- }
-
-- if (share_count) {
-+ if (share_count > 1) {
- /* Duplicate the sensor records for each instance. Go
- backwards to avoid destroying the first one until we
- finish the others. */