aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-08-30 22:25:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-08-30 22:25:46 +0000
commit1af4de9a34cb08db6e76ce759b24ccd9eb9752b5 (patch)
tree4406446e13eb9d8177adef00ef3d08b174be19b8 /textproc/aspell
parent0a9e867ba5004ac44248f57d0f46f9ed2e9c9739 (diff)
downloadports-1af4de9a34cb08db6e76ce759b24ccd9eb9752b5.tar.gz
ports-1af4de9a34cb08db6e76ce759b24ccd9eb9752b5.zip
Explicitly disable threading:
- on FreeBSD 4.x, it links with -pthread, but no link is retained in the resulting library; - on FreeBSD 5.x and 6, it works, but since libaspell is used by un-threaded programs, this is not a good choice. Reviewed by: marcus.
Notes
Notes: svn path=/head/; revision=117709
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index c0c48d23dcbc..0d68cbafbe2b 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= aspell
PORTVERSION= 0.60
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= aspell
@@ -26,6 +26,8 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
--enable-static
+PTHREAD_CFLAGS= # Disable threading
+PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes