aboutsummaryrefslogtreecommitdiff
path: root/textproc/bar
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-20 18:01:27 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-20 18:01:27 +0000
commit907c955c0725faa94d54b662114085508e950014 (patch)
treef15e955d7d62e5da4fd6838bb68f8e567d0b1459 /textproc/bar
parentdbcd1fc8e981bc2cb4dffbce30461f4ebded0822 (diff)
downloadports-907c955c0725faa94d54b662114085508e950014.tar.gz
ports-907c955c0725faa94d54b662114085508e950014.zip
This is a small shell script intended to be used in portable Unix install
scripts for showing progress bars. PR: ports/81216 Submitted by: Erik Greenwald <erik@smluc.org>
Notes
Notes: svn path=/head/; revision=135725
Diffstat (limited to 'textproc/bar')
-rw-r--r--textproc/bar/Makefile25
-rw-r--r--textproc/bar/distinfo2
-rw-r--r--textproc/bar/pkg-descr14
3 files changed, 41 insertions, 0 deletions
diff --git a/textproc/bar/Makefile b/textproc/bar/Makefile
new file mode 100644
index 000000000000..7c3546bd4a50
--- /dev/null
+++ b/textproc/bar/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: bar
+# Date created: Wed May 18 2005
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bar
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.theiling.de/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= erik@smluc.org
+COMMENT= Cat with ASCII progress bar
+
+USE_BZIP2= yes
+NO_BUILD= yes
+PLIST_FILES= bin/bar
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bar ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/bar/distinfo b/textproc/bar/distinfo
new file mode 100644
index 000000000000..ff8f47a3c027
--- /dev/null
+++ b/textproc/bar/distinfo
@@ -0,0 +1,2 @@
+MD5 (bar-1.2-src.tar.bz2) = 2f5d5667b08f2a70ea12f2a58a66cefb
+SIZE (bar-1.2-src.tar.bz2) = 4860
diff --git a/textproc/bar/pkg-descr b/textproc/bar/pkg-descr
new file mode 100644
index 000000000000..494c13ec067d
--- /dev/null
+++ b/textproc/bar/pkg-descr
@@ -0,0 +1,14 @@
+This is a small shell script intended to be used in portable Unix install
+scripts for showing progress bars.
+
+The overall goal is to write a minimally complex shell script (thus a program
+that needs no compilation) that is as robust as possible to work on as many
+Bourne shells and operating systems as possible, and that implements 'cat'
+with an ASCII progress bar and some other nifty features.
+
+This is pure Bourne shell code. (For sh, ash, ksh, zsh, bash, ...)
+
+The script is mainly indented to be used in portable install scripts, where
+you can use the body of the script.
+
+WWW: http://www.theiling.de/projects/bar.html