aboutsummaryrefslogtreecommitdiff
path: root/textproc/btparse
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 18:36:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 18:36:06 +0000
commit30e54bba97b4963a082ac761d643df8579f7cc43 (patch)
tree4c86a4dcfa4f9604967b928ee7ee11a3d4ef32aa /textproc/btparse
parent738cc84c875e6903020ce3cb89f51408674b954a (diff)
downloadports-30e54bba97b4963a082ac761d643df8579f7cc43.tar.gz
ports-30e54bba97b4963a082ac761d643df8579f7cc43.zip
btparse is a C library for parsing and processing BibTeX files.
It provides a lexical scanner and LR parser (constructed by PCCTS), both of which are efficient and offer good error detection and recovery; a set of functions for traversing the AST (abstract syntax tree) generated by the parser; and utility functions for manipulating strings according to BibTeX conventions. WWW: http://www.gerg.ca/software/btOOL PR: ports/94686 Submitted by: Kay Lehmann <kay_lehmann@web.de>
Notes
Notes: svn path=/head/; revision=157765
Diffstat (limited to 'textproc/btparse')
-rw-r--r--textproc/btparse/Makefile25
-rw-r--r--textproc/btparse/distinfo3
-rw-r--r--textproc/btparse/files/patch-Makefile.in11
-rw-r--r--textproc/btparse/pkg-descr8
-rw-r--r--textproc/btparse/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/textproc/btparse/Makefile b/textproc/btparse/Makefile
new file mode 100644
index 000000000000..881343956c41
--- /dev/null
+++ b/textproc/btparse/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: btparse
+# Date created: 2006-03-19
+# Whom: Kay Lehmann <kay_lehmann@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= btparse
+PORTVERSION= 0.35
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AM/AMBS/${PORTNAME}
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= C library for parsing and processing BibTeX data files
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_PERL5_BUILD=yes
+
+MAN3= btparse.3 bt_language.3 bt_input.3 bt_traversal.3 \
+ bt_postprocess.3 bt_macros.3 bt_split_names.3 \
+ bt_format_names.3 bt_misc.3
+
+.include <bsd.port.mk>
diff --git a/textproc/btparse/distinfo b/textproc/btparse/distinfo
new file mode 100644
index 000000000000..bdf94449d9de
--- /dev/null
+++ b/textproc/btparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (btparse-0.35.tar.gz) = b71ea8ccd30873356d33d62e36ac63f0
+SHA256 (btparse-0.35.tar.gz) = 631bf1b79dfd4c83377b416a12c349fe88ee37448dc82e41424b2f364a99477b
+SIZE (btparse-0.35.tar.gz) = 470546
diff --git a/textproc/btparse/files/patch-Makefile.in b/textproc/btparse/files/patch-Makefile.in
new file mode 100644
index 000000000000..c160ea838b43
--- /dev/null
+++ b/textproc/btparse/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Mar 19 11:21:45 2006
++++ Makefile.in Sun Mar 19 11:22:15 2006
+@@ -139,7 +139,7 @@
+ SUBDIRS = src tests progs doc
+ EXTRA_DIST = $(wildcard pccts/*.[ch]) btparse.pc.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)/../libdata/pkgconfig
+ pkgconfig_DATA = btparse.pc
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/textproc/btparse/pkg-descr b/textproc/btparse/pkg-descr
new file mode 100644
index 000000000000..0a9025450707
--- /dev/null
+++ b/textproc/btparse/pkg-descr
@@ -0,0 +1,8 @@
+btparse is a C library for parsing and processing BibTeX files.
+It provides a lexical scanner and LR parser (constructed by PCCTS),
+both of which are efficient and offer good error detection and
+recovery; a set of functions for traversing the AST (abstract
+syntax tree) generated by the parser; and utility functions for
+manipulating strings according to BibTeX conventions.
+
+WWW: http://www.gerg.ca/software/btOOL
diff --git a/textproc/btparse/pkg-plist b/textproc/btparse/pkg-plist
new file mode 100644
index 000000000000..6c3b4a51145b
--- /dev/null
+++ b/textproc/btparse/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/bibparse
+include/btparse.h
+lib/libbtparse.so.0
+lib/libbtparse.so
+lib/libbtparse.la
+lib/libbtparse.a
+libdata/pkgconfig/btparse.pc