aboutsummaryrefslogtreecommitdiff
path: root/textproc/cl-meta-clisp
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-10-03 07:27:06 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-10-03 07:27:06 +0000
commit20e83f052e3b0042646b19b914d8d0b91db59601 (patch)
tree8095050b42e1757194565e92a603fcb3106fff36 /textproc/cl-meta-clisp
parentb606d4dabb7f43e0327dd5b236d56ce57a1a2a37 (diff)
downloadports-20e83f052e3b0042646b19b914d8d0b91db59601.tar.gz
ports-20e83f052e3b0042646b19b914d8d0b91db59601.zip
Add cl-meta-clisp 20011114.1, a parser generator for Common Lisp.
META is builder for recursive descent parsers implemented as a domain specific language on top of Common Lisp. PR: 52364 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Notes
Notes: svn path=/head/; revision=90076
Diffstat (limited to 'textproc/cl-meta-clisp')
-rw-r--r--textproc/cl-meta-clisp/Makefile40
-rw-r--r--textproc/cl-meta-clisp/pkg-descr8
-rw-r--r--textproc/cl-meta-clisp/pkg-plist3
3 files changed, 51 insertions, 0 deletions
diff --git a/textproc/cl-meta-clisp/Makefile b/textproc/cl-meta-clisp/Makefile
new file mode 100644
index 000000000000..4b9303fe2d0a
--- /dev/null
+++ b/textproc/cl-meta-clisp/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: cl-meta-clisp
+# Date created: 20. March 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= meta
+PORTVERSION= 20011114.1
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ ftp://www.aarg.net/pub/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -clisp
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= A parser generator for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/meta/meta.asd:${PORTSDIR}/textproc/cl-meta \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/meta/meta.asd:${PORTSDIR}/textproc/cl-meta \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
+
+do-build:
+ FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
+ clisp -q -ansi -norc -E ISO-8859-1 \
+ -i ${LOCALBASE}/etc/asdf-init \
+ -x "(asdf:oos 'asdf:compile-op :meta)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/meta/clispfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/meta/clispfasl/
+
+.include <bsd.port.mk>
diff --git a/textproc/cl-meta-clisp/pkg-descr b/textproc/cl-meta-clisp/pkg-descr
new file mode 100644
index 000000000000..f89d37ce3079
--- /dev/null
+++ b/textproc/cl-meta-clisp/pkg-descr
@@ -0,0 +1,8 @@
+META is builder for recursive descent parsers implemented as a domain
+specific language on top of Common Lisp.
+
+This package installs binaries for CLISP.
+
+WWW: http://home.pipeline.com/~hbaker1/Prag-Parse.html
+
+-- Henrik Motakef
diff --git a/textproc/cl-meta-clisp/pkg-plist b/textproc/cl-meta-clisp/pkg-plist
new file mode 100644
index 000000000000..aaa2cc27a9d7
--- /dev/null
+++ b/textproc/cl-meta-clisp/pkg-plist
@@ -0,0 +1,3 @@
+lib/common-lisp/meta/clispfasl/package.fasl
+lib/common-lisp/meta/clispfasl/meta.fasl
+@dirrm lib/common-lisp/meta/clispfasl