aboutsummaryrefslogtreecommitdiff
path: root/textproc/cl-meta-sbcl
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /textproc/cl-meta-sbcl
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
downloadports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.tar.gz
ports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Notes
Notes: svn path=/head/; revision=247937
Diffstat (limited to 'textproc/cl-meta-sbcl')
-rw-r--r--textproc/cl-meta-sbcl/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/textproc/cl-meta-sbcl/Makefile b/textproc/cl-meta-sbcl/Makefile
index 53a55357bb1a..4338a608eccc 100644
--- a/textproc/cl-meta-sbcl/Makefile
+++ b/textproc/cl-meta-sbcl/Makefile
@@ -6,32 +6,23 @@
PORTNAME= meta
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= textproc lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -sbcl
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A parser generator for Common Lisp
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/meta/meta.asd:${PORTSDIR}/textproc/cl-meta \
- sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/meta/meta.asd:${PORTSDIR}/textproc/cl-meta \
- sbcl:${PORTSDIR}/lang/sbcl
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/meta/meta.asd:${PORTSDIR}/textproc/cl-meta
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/meta/meta.asd:${PORTSDIR}/textproc/cl-meta
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- sbcl --noinform --userinit /dev/null \
- --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
- --eval "(asdf:oos 'asdf:compile-op :meta)" \
- --eval "(quit)"
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/meta/sbclfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/meta/sbclfasl/
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>