aboutsummaryrefslogtreecommitdiff
path: root/textproc/clucene/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 01:45:03 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 01:45:03 +0000
commitf6858c0da4e49dd7ffdbf4a7d63dcea63e2457e9 (patch)
treee9704eb3405cdd27892b743394355468b147a8bc /textproc/clucene/Makefile
parent28e5e224400857dc508a6f066389081f887386a7 (diff)
downloadports-f6858c0da4e49dd7ffdbf4a7d63dcea63e2457e9.tar.gz
ports-f6858c0da4e49dd7ffdbf4a7d63dcea63e2457e9.zip
- CLucene is a C++ port of Lucene: the high-performance,
full-featured text search engine written in Java. CLucene is faster than lucene as it is written in C++.
Notes
Notes: svn path=/head/; revision=170232
Diffstat (limited to 'textproc/clucene/Makefile')
-rw-r--r--textproc/clucene/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/clucene/Makefile b/textproc/clucene/Makefile
new file mode 100644
index 000000000000..f928ff0c0ac7
--- /dev/null
+++ b/textproc/clucene/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: clucene
+# Date created: 2006-08-09
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clucene
+PORTVERSION= 0.9.15
+CATEGORIES= textproc
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-core-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= CLucene is a C++ port of Lucene
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-ascii
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GCC= 3.2+
+USE_AUTOTOOLS= libtool:15
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500016
+CONFIGURE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+.endif
+
+.include <bsd.port.post.mk>