aboutsummaryrefslogtreecommitdiff
path: root/textproc/confetti
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-01 10:34:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-01 10:34:25 +0000
commitb8fd1bfb6582a1f6b6890cc7cbf2e72d66b58bc2 (patch)
tree8930aa6522652e028da0b96c736c00e09f7639a9 /textproc/confetti
parentdfadb7962a1ea8f681f1a5c8c203731ccb08b148 (diff)
downloadports-b8fd1bfb6582a1f6b6890cc7cbf2e72d66b58bc2.tar.gz
ports-b8fd1bfb6582a1f6b6890cc7cbf2e72d66b58bc2.zip
confetti -- configuration file parser generator
WWW: https://github.com/mailru/confetti PR: ports/170336 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306791
Diffstat (limited to 'textproc/confetti')
-rw-r--r--textproc/confetti/Makefile44
-rw-r--r--textproc/confetti/distinfo2
-rw-r--r--textproc/confetti/pkg-descr3
-rw-r--r--textproc/confetti/pkg-plist8
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/confetti/Makefile b/textproc/confetti/Makefile
new file mode 100644
index 000000000000..e57e24e8a03c
--- /dev/null
+++ b/textproc/confetti/Makefile
@@ -0,0 +1,44 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= confetti
+PORTVERSION= 0.0.${DATE}
+CATEGORIES= textproc
+MASTER_SITES= http://fbsd.zlonet.ru/distfiles/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Configuration file parser generator
+
+BUILD_DEPENDS= flex:${PORTSDIR}/textproc/flex
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_BISON= build
+USE_PERL5= yes
+DATE= 20120801
+MAKE_ARGS+= FLEX=${LOCALBASE}/bin/flex
+MAKE_JOBS_UNSAFE=yes
+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC=|CC?=|' -e 's|CFLAGS=|CFLAGS?=|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} example ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/confetti/distinfo b/textproc/confetti/distinfo
new file mode 100644
index 000000000000..21e647187922
--- /dev/null
+++ b/textproc/confetti/distinfo
@@ -0,0 +1,2 @@
+SHA256 (confetti-0.0.20120801.tar.bz2) = 7bc6a4bbfb7465adf0a9af80f03dd1bd21d96244a7b6887b2e7cfb2a9dadfd3b
+SIZE (confetti-0.0.20120801.tar.bz2) = 120800
diff --git a/textproc/confetti/pkg-descr b/textproc/confetti/pkg-descr
new file mode 100644
index 000000000000..fe7593777159
--- /dev/null
+++ b/textproc/confetti/pkg-descr
@@ -0,0 +1,3 @@
+confetti -- configuration file parser generator
+
+WWW: https://github.com/mailru/confetti
diff --git a/textproc/confetti/pkg-plist b/textproc/confetti/pkg-plist
new file mode 100644
index 000000000000..597af37250fb
--- /dev/null
+++ b/textproc/confetti/pkg-plist
@@ -0,0 +1,8 @@
+bin/confetti
+%%EXAMPLES%%%%EXAMPLESDIR%%/example/example.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/example/Makefile
+%%EXAMPLES%%%%EXAMPLESDIR%%/example/my_my_product.cfg
+%%EXAMPLES%%%%EXAMPLESDIR%%/example/example_buffer.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/example/example.cfgtmpl
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/example
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%