aboutsummaryrefslogtreecommitdiff
path: root/textproc/cwtext
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-16 03:46:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-16 03:46:52 +0000
commit4ed575d2cafe0874c60ca959d546c064040fdd12 (patch)
treefdf59d440fd28f07c60712c7fd5ca88225865e3d /textproc/cwtext
parent2f79220caf7a319d3c2c60cf3bb1ae55fee6215e (diff)
downloadports-4ed575d2cafe0874c60ca959d546c064040fdd12.tar.gz
ports-4ed575d2cafe0874c60ca959d546c064040fdd12.zip
add cwtext
Morse Code Generator
Notes
Notes: svn path=/head/; revision=50109
Diffstat (limited to 'textproc/cwtext')
-rw-r--r--textproc/cwtext/Makefile30
-rw-r--r--textproc/cwtext/distinfo1
-rw-r--r--textproc/cwtext/pkg-comment1
-rw-r--r--textproc/cwtext/pkg-descr16
-rw-r--r--textproc/cwtext/pkg-plist2
5 files changed, 50 insertions, 0 deletions
diff --git a/textproc/cwtext/Makefile b/textproc/cwtext/Makefile
new file mode 100644
index 000000000000..5fb947a14331
--- /dev/null
+++ b/textproc/cwtext/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: cwtext
+# Date created: Nov 16, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cwtext
+PORTVERSION= 0.90
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+MAKEFILE= makefile
+ALL_TARGET= ALL
+
+post-patch:
+ @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ s,gcc,${CC} ${CFLAGS},g" ${WRKSRC}/${MAKEFILE}
+
+do-install:
+.for file in cwpcm cwtext
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/cwtext/distinfo b/textproc/cwtext/distinfo
new file mode 100644
index 000000000000..a77fc3173810
--- /dev/null
+++ b/textproc/cwtext/distinfo
@@ -0,0 +1 @@
+MD5 (cwtext-0.90.tar.gz) = 15257a2e570d4c4d8eea6a9be3170724
diff --git a/textproc/cwtext/pkg-comment b/textproc/cwtext/pkg-comment
new file mode 100644
index 000000000000..6af1a1fc801f
--- /dev/null
+++ b/textproc/cwtext/pkg-comment
@@ -0,0 +1 @@
+Morse Code Generator
diff --git a/textproc/cwtext/pkg-descr b/textproc/cwtext/pkg-descr
new file mode 100644
index 000000000000..b4020657af0c
--- /dev/null
+++ b/textproc/cwtext/pkg-descr
@@ -0,0 +1,16 @@
+About the project
+
+We plan to build a program that will accept ASCII text as input and generate
+International Morse Code as output. The output formats can be:
+
+ - . -..- - (text) on the console
+ Raw audio on /dev/audio (8bit PCM data)
+ .wav files
+ .ogg or (proprietary format) compressed audio
+
+International Morse Code
+
+Supported character set includes [A-Za-z] (all downcased as Morse is not case
+sensitive), [0-9], ",-.?/" plus a few procedural characters (SK, AR, BT etc).
+
+WWW: http://cwtext.sourceforge.net/
diff --git a/textproc/cwtext/pkg-plist b/textproc/cwtext/pkg-plist
new file mode 100644
index 000000000000..a8a254e66565
--- /dev/null
+++ b/textproc/cwtext/pkg-plist
@@ -0,0 +1,2 @@
+bin/cwpcm
+bin/cwtext