aboutsummaryrefslogtreecommitdiff
path: root/textproc/docproj
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2004-08-20 17:34:16 +0000
committerHiroki Sato <hrs@FreeBSD.org>2004-08-20 17:34:16 +0000
commitaa0caf5ff3a8f8cba9876229064bedd7af2f36f0 (patch)
treef0d46c730044b50166cad6b2c4ce9c264e0354af /textproc/docproj
parent645378402e935df7c949b3e854e2e42ed526c345 (diff)
downloadports-aa0caf5ff3a8f8cba9876229064bedd7af2f36f0.tar.gz
ports-aa0caf5ff3a8f8cba9876229064bedd7af2f36f0.zip
- Fix dependencies.
- Use WITH_JADETEX instead of JADETEX. - Use USE_GHOSTSCRIPT. Reviewed by: doceng
Notes
Notes: svn path=/head/; revision=116805
Diffstat (limited to 'textproc/docproj')
-rw-r--r--textproc/docproj/Makefile81
-rw-r--r--textproc/docproj/files/JADETEX12
-rw-r--r--textproc/docproj/pkg-plist1
3 files changed, 57 insertions, 37 deletions
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 0710323d1737..485134c8ac3e 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= docproj
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= textproc
MASTER_SITES= # empty
DISTFILES= # empty
+EXTRACT_ONLY= # empty
MAINTAINER= doceng@freebsd.org
COMMENT= The "meta-port" for the FreeBSD Documentation Project
@@ -17,48 +18,68 @@ COMMENT= The "meta-port" for the FreeBSD Documentation Project
# This dependency list should be kept in sync with the list of
# required ports in src/release/Makefile.inc.docports.
-RUN_DEPENDS= instant:${PORTSDIR}/textproc/sgmlformat \
+RUN_DEPENDS= links:${PORTSDIR}/www/links1 \
+ pngtopnm:${PORTSDIR}/graphics/netpbm \
+ scr2png:${PORTSDIR}/graphics/scr2png \
+ scr2txt:${PORTSDIR}/textproc/scr2txt \
tidy:${PORTSDIR}/www/tidy \
- ${PREFIX}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
- ${PREFIX}/share/sgml/html/catalog:${PORTSDIR}/textproc/html \
- ${PREFIX}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
- ${PREFIX}/share/sgml/docbook/4.1/docbook.dtd:${PORTSDIR}/textproc/docbook-410 \
- ${PREFIX}/share/sgml/iso8879:${PORTSDIR}/textproc/iso8879 \
- ${PREFIX}/share/xml/dtd/xhtml/xhtml.soc:${PORTSDIR}/textproc/xhtml \
- ${PREFIX}/bin/peps:${PORTSDIR}/graphics/peps \
- ${PREFIX}/bin/pngtopnm:${PORTSDIR}/graphics/netpbm \
- ${PREFIX}/bin/links:${PORTSDIR}/www/links1 \
- ${PREFIX}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
- ${PREFIX}/bin/scr2png:${PORTSDIR}/graphics/scr2png \
- ${PREFIX}/bin/scr2txt:${PORTSDIR}/textproc/scr2txt \
- ${PREFIX}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
- ${PREFIX}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
-
-.if defined(WITH_OPENJADE) || ${MACHINE_ARCH} != "i386"
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ ${LOCALBASE}/share/sgml/html/catalog:${PORTSDIR}/textproc/html \
+ ${LOCALBASE}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
+ ${LOCALBASE}/share/sgml/docbook/4.1/docbook.dtd:${PORTSDIR}/textproc/docbook-410 \
+ ${LOCALBASE}/share/sgml/iso8879:${PORTSDIR}/textproc/iso8879 \
+ ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:${PORTSDIR}/textproc/xhtml \
+ ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENJADE) || ${ARCH} != "i386"
RUN_DEPENDS+= openjade:${PORTSDIR}/textproc/openjade
.else
RUN_DEPENDS+= jade:${PORTSDIR}/textproc/jade
.endif
-.if !defined(JADETEX)
-IS_INTERACTIVE= "user must set JADETEX variable to 'yes' or 'no'"
+.if defined(JADETEX)
+WITH_JADETEX= ${JADETEX}
.endif
+WITH_JADETEX?=
+
+.if defined(WITH_JADETEX) && ${WITH_JADETEX} == yes
+RUN_DEPENDS+= ${LOCALBASE}/share/texmf/web2c/jadetex.fmt:${PORTSDIR}/print/jadetex
+.endif
+
+NO_BUILD= yes
+USE_GHOSTSCRIPT= yes
+PLIST_FILES= #empty
-JADETEX?=
+WITHOUT_X11= yes
+DEPENDS_ARGS+= BATCH=yes WITHOUT_X11=${WITHOUT_X11}
-.if empty(JADETEX) && (make(build) || make(install))
-.BEGIN:
+IS_INTERACTIVE= "user must set WITH_JADETEX variable to 'yes' or 'no'"
+
+message-jadetex:
@${CAT} ${FILESDIR}/JADETEX
@${FALSE}
-.endif
+message-gs:
+ @${ECHO_MSG} "NOTICE: Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one."
+ @${ECHO_MSG} ""
-.if ${JADETEX} == yes
-RUN_DEPENDS+= ${PREFIX}/share/texmf/web2c/jadetex.fmt:${PORTSDIR}/print/jadetex
-.endif
+# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
+# (XXX: incomplete yet)
+minimaldocports:
+ @${ECHO_CMD} "MINIMALDOCPORTS= \\"
+ @${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
-EXTRACT_ONLY= # empty
-NO_BUILD= yes
+.if empty(WITH_JADETEX) && !make(deinstall)
+pre-everything:: message-jadetex
+.endif
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+pre-everything:: message-gs
+.endif
do-install: # empty
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/docproj/files/JADETEX b/textproc/docproj/files/JADETEX
index f2f7379f5536..f040c4a8cf4f 100644
--- a/textproc/docproj/files/JADETEX
+++ b/textproc/docproj/files/JADETEX
@@ -2,16 +2,16 @@ This port will try and ensure that the tools used by the FreeBSD
Documentation Project are installed on your system so you can convert
documentation from SGML to other formats.
-One of these components is JadeTeX, which depends on TeTeX. The source
-for TeTeX is larger than 30MB, and may be a very long download for you.
+One of these components is JadeTeX, which depends on teTeX. The source
+for teTeX is larger than 30MB, and may be a very long download for you.
If you do not want to produce PostScript and PDF formats from the
documentation then you do not need JadeTeX, and you should set the
-variable "JADETEX" to "no". If you do want to produce PostScript and
-PDF output then set "JADETEX" to yes.
+variable "WITH_JADETEX" to "no". If you do want to produce PostScript and
+PDF output then set "WITH_JADETEX" to yes.
For example;
- make JADETEX=no
- make JADETEX=yes
+ make WITH_JADETEX=no
+ make WITH_JADETEX=yes
diff --git a/textproc/docproj/pkg-plist b/textproc/docproj/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/textproc/docproj/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty