aboutsummaryrefslogtreecommitdiff
path: root/textproc/expat2
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-03-14 07:57:43 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-03-14 07:57:43 +0000
commit8e9dca3d94fe335ede6da94f41dabe6fec5e23f6 (patch)
tree7a93ae1d3fd6e24db68c78b82e3bb38a23495737 /textproc/expat2
parent189664d44fa98be98e6cd6e19f1e0728f34b1d46 (diff)
downloadports-8e9dca3d94fe335ede6da94f41dabe6fec5e23f6.tar.gz
ports-8e9dca3d94fe335ede6da94f41dabe6fec5e23f6.zip
Upgrade to 1.95.7 (shlib major is bumped to 5).
Notes
Notes: svn path=/head/; revision=103968
Diffstat (limited to 'textproc/expat2')
-rw-r--r--textproc/expat2/Makefile11
-rw-r--r--textproc/expat2/distinfo3
-rw-r--r--textproc/expat2/files/patch-expat.h62
3 files changed, 10 insertions, 66 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index b5597d04249f..64e712efd548 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= expat
-PORTVERSION= 1.95.6
-PORTREVISION= 1
+PORTVERSION= 1.95.7
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= expat
@@ -21,10 +20,16 @@ ALL_TARGET= default
INSTALLS_SHLIB= yes
MAN1= xmlwf.1
-SHLIB_MAJOR= 4
+SHLIB_MAJOR= 5
MAKE_ENV= LIBCURRENT="${SHLIB_MAJOR}" \
SHELL="/bin/sh"
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+list-depend-ports:
+ cd ${PORTSDIR}; \
+ find . -mindepth 3 -maxdepth 3 -name Makefile -execdir sh -c \
+ 'find . -type f | grep -v CVS | xargs grep -q expat.5' \; \
+ -print
+
.include <bsd.port.mk>
diff --git a/textproc/expat2/distinfo b/textproc/expat2/distinfo
index 83d72b3fc9ad..9873e2ff3bab 100644
--- a/textproc/expat2/distinfo
+++ b/textproc/expat2/distinfo
@@ -1 +1,2 @@
-MD5 (expat-1.95.6.tar.gz) = ca78d94e83e9f077b5da2bfe28ba986a
+MD5 (expat-1.95.7.tar.gz) = 2ff59c2a5cbdd21a285c5f343e214fa9
+SIZE (expat-1.95.7.tar.gz) = 296718
diff --git a/textproc/expat2/files/patch-expat.h b/textproc/expat2/files/patch-expat.h
deleted file mode 100644
index 1399f19289ec..000000000000
--- a/textproc/expat2/files/patch-expat.h
+++ /dev/null
@@ -1,62 +0,0 @@
---- lib/expat.h.orig Fri Jan 17 07:03:42 2003
-+++ lib/expat.h Thu Feb 6 10:19:21 2003
-@@ -57,6 +57,26 @@
- #define XML_TRUE ((XML_Bool) 1)
- #define XML_FALSE ((XML_Bool) 0)
-
-+/* The XML_Status enum gives the possible return values for several
-+ API functions. The preprocessor #defines are included so this
-+ stanza can be added to code that still needs to support older
-+ versions of Expat 1.95.x:
-+
-+ #ifndef XML_STATUS_OK
-+ #define XML_STATUS_OK 1
-+ #define XML_STATUS_ERROR 0
-+ #endif
-+
-+ Otherwise, the #define hackery is quite ugly and would have been
-+ dropped.
-+*/
-+enum XML_Status {
-+ XML_STATUS_ERROR = 0,
-+#define XML_STATUS_ERROR XML_STATUS_ERROR
-+ XML_STATUS_OK = 1
-+#define XML_STATUS_OK XML_STATUS_OK
-+};
-+
- enum XML_Error {
- XML_ERROR_NONE,
- XML_ERROR_NO_MEMORY,
-@@ -717,28 +737,11 @@
- detected. The last call to XML_Parse must have isFinal true; len
- may be zero for this call (or any other).
-
-- The XML_Status enum gives the possible return values for the
-- XML_Parse and XML_ParseBuffer functions. Though the return values
-- for these functions has always been described as a Boolean value,
-- the implementation, at least for the 1.95.x series, has always
-- returned exactly one of these values. The preprocessor #defines
-- are included so this stanza can be added to code that still needs
-- to support older versions of Expat 1.95.x:
--
-- #ifndef XML_STATUS_OK
-- #define XML_STATUS_OK 1
-- #define XML_STATUS_ERROR 0
-- #endif
--
-- Otherwise, the #define hackery is quite ugly and would have been dropped.
-+ Though the return values for these functions has always been
-+ described as a Boolean value, the implementation, at least for the
-+ 1.95.x series, has always returned exactly one of the XML_Status
-+ values.
- */
--enum XML_Status {
-- XML_STATUS_ERROR = 0,
--#define XML_STATUS_ERROR XML_STATUS_ERROR
-- XML_STATUS_OK = 1
--#define XML_STATUS_OK XML_STATUS_OK
--};
--
- XMLPARSEAPI(enum XML_Status)
- XML_Parse(XML_Parser parser, const char *s, int len, int isFinal);
-