aboutsummaryrefslogtreecommitdiff
path: root/textproc/gsed
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-02-03 12:06:11 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-02-03 12:06:11 +0000
commitdfb8cff650c40389bd4b8d6d3af2d1375b6e0111 (patch)
treea7fda59ec16849359a17b41b4a1716fa80544d09 /textproc/gsed
parent92e4ca375ea03ca52ba8ee3fcf8ea1ebdb98f0ae (diff)
downloadports-dfb8cff650c40389bd4b8d6d3af2d1375b6e0111.tar.gz
ports-dfb8cff650c40389bd4b8d6d3af2d1375b6e0111.zip
Improve the general appearance of this port:
- PORTNAME changed to sed; - PKGNAMEPREFIX added so the package name is still gsed; - do-install removed, using the real sed install target; - a typo fixed in pkg-descr. - maintainer changed to Cyrille Lefevre PR: 24719 Submitted by: Cyrille Lefevre <clefevre@citeweb.net> - new maintainer
Notes
Notes: svn path=/head/; revision=37921
Diffstat (limited to 'textproc/gsed')
-rw-r--r--textproc/gsed/Makefile57
-rw-r--r--textproc/gsed/pkg-descr2
2 files changed, 47 insertions, 12 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index d11e5259bb38..f09da1fbc421 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -5,28 +5,63 @@
# $FreeBSD$
#
-PORTNAME= gsed
+PORTNAME= sed
PORTVERSION= 3.02
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= sed
-DISTNAME= sed-${PORTVERSION}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= g
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= clefevre@citeweb.net
+
+#
+# Global variables
+#
GNU_CONFIGURE= yes
# sed's configure seems to be buggy !
# CONFIGURE_ARGS= --program-prefix=g
+USE_GMAKE= yes
+
+.if make(do-install)
+# DESTDIR isn't honored. fake it w/ prefix.
+MAKE_ARGS= prefix=${PREFIX}
+.endif
+
MAN1= gsed.1
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sed/sed ${PREFIX}/bin/gsed
- ${INSTALL_MAN} ${WRKSRC}/doc/sed.1 ${PREFIX}/man/man1/gsed.1
- ${INSTALL_DATA} ${WRKSRC}/doc/sed.info ${PREFIX}/info
- @install-info ${PREFIX}/info/sed.info ${PREFIX}/info/dir
- @${MKDIR} ${PREFIX}/share/examples/gsed
- ${INSTALL_DATA} ${WRKSRC}/dc.sed ${PREFIX}/share/examples/gsed
+#
+# Local variables
+#
+
+PATCH_SUBDIRS= . doc lib sed
+
+SAMP_FILES= dc.sed
+SAMP_DIR= ${PREFIX}/share/examples/${PKGBASE}
+
+#
+# Post-configure
+#
+
+post-configure: patch-makefiles
+
+patch-makefiles:
+.for subdir in ${PATCH_SUBDIRS}
+ @${PERL} -pi.fbsd -e 's/s,x,x,/s,^,g,/' ${WRKSRC}/${subdir}/Makefile
+.endfor
+
+#
+# Post-install
+#
+
+post-install: install-sample-files
+
+install-sample-files:
+ @${MKDIR} ${SAMP_DIR}
+.for file in ${SAMP_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${SAMP_DIR}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/textproc/gsed/pkg-descr b/textproc/gsed/pkg-descr
index 814263961c9c..59c4d0b55393 100644
--- a/textproc/gsed/pkg-descr
+++ b/textproc/gsed/pkg-descr
@@ -4,7 +4,7 @@ This utility exist in the FreeBSD base collection, but the GNU
versions have added functionality that is sometimes useful.
Note that this port will install this utility with a `g' prefix,
-eg., gsed, but the texinfo documentation will refer to these
+for example gsed, but the texinfo documentation will refer to these
utilities without the `g' prefix.
WWW: http://www.gnu.org/software/sed/sed.html