aboutsummaryrefslogtreecommitdiff
path: root/textproc/highlight/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-21 01:18:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-21 01:18:30 +0000
commitece4b9020523a4cdb5ed6978836b3817ada4c63e (patch)
tree3feae4dede93ca542dbeed363c8ebb27822b39d3 /textproc/highlight/Makefile
parent76647a95c114a08da34b86edfe9396b1d9961030 (diff)
downloadports-ece4b9020523a4cdb5ed6978836b3817ada4c63e.tar.gz
ports-ece4b9020523a4cdb5ed6978836b3817ada4c63e.zip
upgrade to 2.0.25
Notes
Notes: svn path=/head/; revision=111900
Diffstat (limited to 'textproc/highlight/Makefile')
-rw-r--r--textproc/highlight/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index d5a1df3d16f5..d3df3ae62d2a 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= highlight
-PORTVERSION= 2.0.23
-PORTEPOCH= 1
+PORTVERSION= 2.0.25
+PORTEPOCH= 0
CATEGORIES= textproc
MASTER_SITES= http://www.andre-simon.de/zip/
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -27,9 +27,17 @@ MAKE_ARGS= CC="${CXX}" \
LDFLAGS="${LDFLAGS}"
ALL_TARGET= ${PORTNAME}
+PLIST_FILES= bin/highlight
+
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/share/highlight|${DATADIR}|' ${WRKSRC}/datadir.cpp
@@ -56,4 +64,12 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+post-install:
+.for dir in ${PREFIX}/share/${PORTNAME} ${PREFIX}/share/examples/${PORTNAME}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>