aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-Diff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-12 16:33:59 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-12 16:33:59 +0000
commitec29a59ec3d0472e808e9907b2f18dce2e9fe68c (patch)
treebd2ff04188a74e09a51bfecae86236b3684491e5 /textproc/hs-Diff
parentba00ef6b8cc071eb53bf9287bfbc328da82f7eb8 (diff)
downloadports-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.tar.gz
ports-ec29a59ec3d0472e808e9907b2f18dce2e9fe68c.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Notes
Notes: svn path=/head/; revision=254209
Diffstat (limited to 'textproc/hs-Diff')
-rw-r--r--textproc/hs-Diff/Makefile61
-rw-r--r--textproc/hs-Diff/pkg-plist20
2 files changed, 11 insertions, 70 deletions
diff --git a/textproc/hs-Diff/Makefile b/textproc/hs-Diff/Makefile
index ae7809996827..6cedcb101162 100644
--- a/textproc/hs-Diff/Makefile
+++ b/textproc/hs-Diff/Makefile
@@ -8,68 +8,9 @@
PORTNAME= Diff
PORTVERSION= 0.1.2
CATEGORIES= textproc haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= O(ND) diff algorithm in haskell
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-
-GHC_VERSION= 6.10.4
-DIFF_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-DIFF_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- DIFF_VERSION=${DIFF_VERSION} \
- DIFF_LIBDIR_REL=${DIFF_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${DIFF_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-Diff/pkg-plist b/textproc/hs-Diff/pkg-plist
index 6b9f07394b7b..b6f30e1fd48e 100644
--- a/textproc/hs-Diff/pkg-plist
+++ b/textproc/hs-Diff/pkg-plist
@@ -1,15 +1,15 @@
@comment $FreeBSD$
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm/Diff.hi
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSDiff-%%DIFF_VERSION%%.o
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSDiff-%%DIFF_VERSION%%.a
-%%DIFF_LIBDIR_REL%%/register.sh
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm/Diff.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%DIFF_LIBDIR_REL%%
-@exec /bin/sh %D/%%DIFF_LIBDIR_REL%%/register.sh
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister Diff
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old