aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-HaXml/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2005-09-11 18:14:02 +0000
committerOliver Braun <obraun@FreeBSD.org>2005-09-11 18:14:02 +0000
commit7989eb4537512fc997411c9c3e89c7aef5d41ef3 (patch)
treeb55712f295559b1bfa9506ae16d66d084a630e3e /textproc/hs-HaXml/Makefile
parenta303b5e5b4f866590f84a9a282aa691b58242e86 (diff)
downloadports-7989eb4537512fc997411c9c3e89c7aef5d41ef3.tar.gz
ports-7989eb4537512fc997411c9c3e89c7aef5d41ef3.zip
Remove also nhc98-bits since the current version of nhc98 already contains
HaXml. Noticed by: jannisan@t-online.de
Notes
Notes: svn path=/head/; revision=142455
Diffstat (limited to 'textproc/hs-HaXml/Makefile')
-rw-r--r--textproc/hs-HaXml/Makefile58
1 files changed, 6 insertions, 52 deletions
diff --git a/textproc/hs-HaXml/Makefile b/textproc/hs-HaXml/Makefile
index 93f26120554b..a96bcdbb3104 100644
--- a/textproc/hs-HaXml/Makefile
+++ b/textproc/hs-HaXml/Makefile
@@ -15,79 +15,33 @@ DISTNAME= HaXml-${PORTVERSION}
MAINTAINER= haskell@FreeBSD.org
COMMENT= A collection of utilities for using Haskell and XML together
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+
USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/nhc98)
-WITH_NHC98= yes
-.endif
-.if exists(${LOCALBASE}/bin/ghc)
-WITH_GHC= yes
-.endif
-
-.if defined(PACKAGE_BUILDING)
-WITH_GHC= yes
-.endif
-
-.if defined(WITH_NHC98)
-BUILD_DEPENDS+= nhc98:${PORTSDIR}/lang/nhc98
-RUN_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
-.endif
-.if defined(WITH_GHC)
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-.endif
-
-.if defined(WITH_NHC98)
-PLIST_SUB+= NHC98=""
-.else
-PLIST_SUB+= NHC98="@comment "
-.endif
-.if defined(WITH_GHC)
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
-PLIST_SUB+= GHC="" GHC_VERSION="${GHC_VERSION}"
-.else
-PLIST_SUB+= GHC="@comment "
-.endif
-
-pre-everything::
- @${ECHO_CMD} ""
-.if defined(WITH_NHC98)
- @${ECHO_CMD} " HaXml will be installed for nhc98."
-.else
- @${ECHO_CMD} " Define WITH_NHC98 to install HaXml for nhc98."
-.endif
-.if defined(WITH_GHC)
- @${ECHO_CMD} " HaXml will be installed for ghc."
-.else
- @${ECHO_CMD} " Define WITH_GHC to install HaXml for ghc."
-.endif
-.if !defined(WITH_GHC) && !defined(WITH_NHC98)
- @${FALSE}
-.endif
- @${ECHO_CMD} ""
+PLIST_SUB+= GHC_VERSION="${GHC_VERSION}"
post-patch:
@${REINPLACE_CMD} -e 's,/bin/false,/usr/bin/false,' ${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e '/hugs/d' ${WRKSRC}/obj/compilers
+ @${REINPLACE_CMD} -e '/nhc98/d' ${WRKSRC}/obj/compilers
post-install:
-.if defined(WITH_GHC)
@${INSTALL_DATA} ${WRKSRC}/obj/ghc/HaXml.pkgconf \
${PREFIX}/lib/ghc-${GHC_VERSION}/imports/HaXml/
@${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC} && ${RM} -rf docs/HaXml/CVS)
@(cd ${WRKSRC} && ${CP} -R docs/* ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>