aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-HaXml
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-02-22 15:36:33 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-02-22 15:36:33 +0000
commit66cc2531933182433f2c7365d8c98b2a7cf2d72c (patch)
tree725fef33bf50dfde423d4191f12658aa7d75badf /textproc/hs-HaXml
parent5307d47cef9ecf70dbb7b46982d31de127816bf2 (diff)
downloadports-66cc2531933182433f2c7365d8c98b2a7cf2d72c.tar.gz
ports-66cc2531933182433f2c7365d8c98b2a7cf2d72c.zip
* Remove forgotten patch and BROKEN.
Submitted by: bento via kris Pointy hat to: me
Notes
Notes: svn path=/head/; revision=101735
Diffstat (limited to 'textproc/hs-HaXml')
-rw-r--r--textproc/hs-HaXml/Makefile2
-rw-r--r--textproc/hs-HaXml/files/patch-src::tools::Xtract34
2 files changed, 0 insertions, 36 deletions
diff --git a/textproc/hs-HaXml/Makefile b/textproc/hs-HaXml/Makefile
index 93081fe8cbd1..03bd08a12355 100644
--- a/textproc/hs-HaXml/Makefile
+++ b/textproc/hs-HaXml/Makefile
@@ -16,8 +16,6 @@ DISTNAME= HaXml-${PORTVERSION}
MAINTAINER= obraun@FreeBSD.org
COMMENT= A collection of utilities for using Haskell and XML together
-BROKEN= "Patch fails"
-
USE_SIZE= yes
USE_REINPLACE= yes
HAS_CONFIGURE= yes
diff --git a/textproc/hs-HaXml/files/patch-src::tools::Xtract b/textproc/hs-HaXml/files/patch-src::tools::Xtract
deleted file mode 100644
index a84ee6beb403..000000000000
--- a/textproc/hs-HaXml/files/patch-src::tools::Xtract
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: src/tools/Xtract.hs
-===================================================================
-RCS file: /home/cvs/root/HaXml/src/tools/Xtract.hs,v
-retrieving revision 1.3
-diff -u -r1.3 Xtract.hs
---- src/tools/Xtract.hs 2 Oct 2002 10:24:06 -0000 1.3
-+++ src/tools/Xtract.hs 27 Aug 2003 16:27:55 -0000
-@@ -11,7 +11,7 @@
- import Text.XML.HaXml.Parse (xmlParse)
- import Text.XML.HaXml.Html.Parse (htmlParse)
- import Text.XML.HaXml.Xtract.Parse (parseXtract)
--import Text.PrettyPrint.HughesPJ (render, vcat)
-+import Text.PrettyPrint.HughesPJ (render, vcat, hcat, empty)
- import Text.XML.HaXml.Pretty (content)
- import Text.XML.HaXml.Html.Generate (htmlprint)
-
-@@ -40,7 +40,7 @@
- ( if isHTML x then
- hPutStrLn stdout . render . htmlprint .
- dfilter htmlSelection . getElem . htmlParse x
-- else hPutStrLn stdout . render . vcat . map content .
-+ else hPutStrLn stdout . render . format .
- dfilter xmlSelection . getElem . xmlParse x) c)
- files
-
-@@ -48,3 +48,8 @@
- isHTML x = ".html" `isSuffixOf` x || ".htm" `isSuffixOf` x
-
- dfilter f = \x-> f x x
-+
-+format [] = empty
-+format cs@(CString _ _:_) = hcat . map content $ cs
-+format cs@(CRef _:_) = hcat . map content $ cs
-+format cs = vcat . map content $ cs