aboutsummaryrefslogtreecommitdiff
path: root/textproc/html2text
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-30 08:33:53 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-30 08:33:53 +0000
commita5b8c840ccb8b911ab37a273dd6ba59190c4aa3e (patch)
tree452197f29c45e023cca1f9776dd0d400e94dc7e4 /textproc/html2text
parente283b384d3d69595403829bb12f3f870621b802a (diff)
downloadports-a5b8c840ccb8b911ab37a273dd6ba59190c4aa3e.tar.gz
ports-a5b8c840ccb8b911ab37a273dd6ba59190c4aa3e.zip
Update to version 1.3.2a
PR: ports/71125 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=117639
Diffstat (limited to 'textproc/html2text')
-rw-r--r--textproc/html2text/Makefile43
-rw-r--r--textproc/html2text/distinfo4
-rw-r--r--textproc/html2text/files/patch-format.C19
-rw-r--r--textproc/html2text/pkg-plist8
4 files changed, 27 insertions, 47 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index 708bdd926b80..9d73cf199408 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -6,37 +6,44 @@
#
PORTNAME= html2text
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.2a
CATEGORIES= textproc
-MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
- ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://userpage.fu-berlin.de/~mbayer/tools/
+MASTER_SITE_SUBDIR= apps/www/converters
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts HTML documents into plain text
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-MANCOMPRESSED= yes
-
-MAN1= html2text.1
-MAN5= html2textrc.5
+HAS_CONFIGURE= yes
+MAKE_ARGS= CXX="${CXX}"
-DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
-
-.include <bsd.port.pre.mk>
+MANCOMPRESSED= yes
+MAN1= html2text.1
+MAN5= html2textrc.5
+PORTDOCS= CHANGES CREDITS KNOWN_BUGS README TODO
+PLIST_FILES= bin/html2text
post-patch:
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/libstd/Makefile.in
+.for file in Makefile.in libstd/Makefile.in
+ @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; \
+ /^CXXFLAGS/s/=/+=/' ${WRKSRC}/${file}
+.endfor
+.for file in Area.h HTMLControl.h Properties.h format.h
+ @${REINPLACE_CMD} -e 's/<istream>/<iostream>/' ${WRKSRC}/${file}
+.endfor
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
- @${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
+ ${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DOCS:C#^#${WRKSRC}/#g} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/html2text/distinfo b/textproc/html2text/distinfo
index 5d7a6d2b801b..697f93300c59 100644
--- a/textproc/html2text/distinfo
+++ b/textproc/html2text/distinfo
@@ -1,2 +1,2 @@
-MD5 (html2text-1.3.2.tar.gz) = 14b091c7c5cb5c3bc2ce19298a0c0e27
-SIZE (html2text-1.3.2.tar.gz) = 131336
+MD5 (html2text-1.3.2a.tar.gz) = 6097fe07b948e142315749e6620c9cfc
+SIZE (html2text-1.3.2a.tar.gz) = 130088
diff --git a/textproc/html2text/files/patch-format.C b/textproc/html2text/files/patch-format.C
deleted file mode 100644
index c1942c85f553..000000000000
--- a/textproc/html2text/files/patch-format.C
+++ /dev/null
@@ -1,19 +0,0 @@
---- format.C Mon Jul 29 20:12:13 2002
-+++ format.C Thu Feb 5 22:47:07 2004
-@@ -34,7 +34,7 @@
- /***************************************************************************/
-
-
--#include <strstream.h>
-+#include <strstream>
-
- #include <stdlib.h>
- #include <ctype.h>
-@@ -50,6 +50,7 @@
-
- using std::endl;
- using std::flush;
-+using std::ostrstream;
-
- #ifndef nelems
- #define nelems(array) (sizeof(array) / sizeof((array)[0]))
diff --git a/textproc/html2text/pkg-plist b/textproc/html2text/pkg-plist
deleted file mode 100644
index 75866489551e..000000000000
--- a/textproc/html2text/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/html2text
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%