aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlc
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2011-04-04 09:08:11 +0000
committerStanislav Sedov <stas@FreeBSD.org>2011-04-04 09:08:11 +0000
commit02c38b36a15046e433f8f24dbec1acfd6c21f342 (patch)
tree9c1db17cfff6fd701a5a68df69e5a929cb6d58b4 /textproc/htmlc
parentbb997f64d01fda3a1168c64e85672a5b9b1de845 (diff)
downloadports-02c38b36a15046e433f8f24dbec1acfd6c21f342.tar.gz
ports-02c38b36a15046e433f8f24dbec1acfd6c21f342.zip
- Fix build with ocaml 3.12.
Notes
Notes: svn path=/head/; revision=272191
Diffstat (limited to 'textproc/htmlc')
-rw-r--r--textproc/htmlc/files/patch-compiler_Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/textproc/htmlc/files/patch-compiler_Makefile b/textproc/htmlc/files/patch-compiler_Makefile
new file mode 100644
index 000000000000..99095b44e95e
--- /dev/null
+++ b/textproc/htmlc/files/patch-compiler_Makefile
@@ -0,0 +1,17 @@
+--- compiler/Makefile.orig 2011-04-04 02:08:25.000000000 -0700
++++ compiler/Makefile 2011-04-04 02:08:42.000000000 -0700
+@@ -37,12 +37,12 @@
+
+ $(PROG).bin: $(BINOBJS)
+ $(CAMLBIN) -o $(PROG).bin str.cmxa unix.cmxa $(BINOBJS) \
+- -cclib -lunix -cclib -lstr && \
++ && \
+ $(RM) $(PROG) && ln -s $(PROG).bin $(PROG)
+
+ $(PROG).byt: $(BYTOBJS)
+ $(CAMLBYT) -g -custom -o $(PROG).byt str.cma unix.cma $(BYTOBJS) \
+- -cclib -lunix -cclib -lstr && \
++ && \
+ $(RM) $(PROG) && ln -s $(PROG).byt $(PROG)
+
+ installbyt: