aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlsection/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-10-05 00:00:52 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-10-05 00:00:52 +0000
commitdbf1723e3c0ecb752db494f772ae8cc5d80f3d56 (patch)
tree92091598316a5fc52a66a063b228c7158437feb3 /textproc/htmlsection/Makefile
parentda7b4d9a195f1388d370a2347770e066f025d544 (diff)
downloadports-dbf1723e3c0ecb752db494f772ae8cc5d80f3d56.tar.gz
ports-dbf1723e3c0ecb752db494f772ae8cc5d80f3d56.zip
Add htmlsection-1.0, Insert section numbers in HTML and make a table of
contents PR: 31040 Submitted by: SAKAI Hiroaki <sakai@miya.ee.kagu.sut.ac.jp>
Notes
Notes: svn path=/head/; revision=48437
Diffstat (limited to 'textproc/htmlsection/Makefile')
-rw-r--r--textproc/htmlsection/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/htmlsection/Makefile b/textproc/htmlsection/Makefile
new file mode 100644
index 000000000000..8ead56fc6d77
--- /dev/null
+++ b/textproc/htmlsection/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: htmlsection
+# Date created: 2 October 2001
+# Whom: SAKAI Hiroaki <sakai@seki.ee.kagu.sut.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlsection
+PORTVERSION= 1.0
+CATEGORIES= textproc www
+MASTER_SITES= http://www.seki.ee.kagu.sut.ac.jp/~sakai/myfreesoft/ \
+ http://hp.vector.co.jp/authors/VA014157/myfreesoft/ \
+ http://www.people.or.jp/~hsakai/myfreesoft/
+
+MAINTAINER= sakai@seki.ee.kagu.sut.ac.jp
+
+MAN1= htmlsection.1
+MANCOMPRESSED= yes
+
+pre-build:
+ @(echo perl is set ${PERL} in pre-build:)
+ @(cd ${WRKSRC}; ./findperl.sh ${PERL} > whereperl)
+ @(cd ${WRKSRC}; ${CAT} whereperl)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/htmlsection ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/htmlsection.1.gz ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in INSTALL README htmlsection_orig.html htmlsection.html
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>