aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-gtk
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 12:18:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 12:18:20 +0000
commit2875c208870c086be504c75c5c57c3e7a1a82680 (patch)
tree54609f665823fb9db4bd76984d87706c9cd85fe8 /textproc/iiimf-gtk
parent633edff8885d2573c8a7e1b4a3149fb0fb702a96 (diff)
downloadports-2875c208870c086be504c75c5c57c3e7a1a82680.tar.gz
ports-2875c208870c086be504c75c5c57c3e7a1a82680.zip
New port: iiimf-*
IIIMF stands for Internet/Intranet Input Method Framework. IIIMF is designed to be the next generation of input method framework which provides the following capabilities; * Multiplatform, platform independent. * Multlingual and Full UNICODE support, but satisfactory for native speakers. * Windowing System Independent. * Multiple language engines concurrently run. * Multiuser. * Distributed, lightweight clients and scalable server. * Extensible in multiple means. * Input method protocol efficient enough to be used over low-speed modem connection. * Easy input method engine development with plugin API. * Easy input method enabling with libiiimcf, even on console apps. * Small core part to start from. WWW: http://www.openi18n.org/subgroups/im/IIIMF/ - Kuang-che Wu kcwu@csie.org PR: ports/60087 Submitted by: Kuang-che Wu <kcwu@csie.org>
Notes
Notes: svn path=/head/; revision=96787
Diffstat (limited to 'textproc/iiimf-gtk')
-rw-r--r--textproc/iiimf-gtk/Makefile41
-rw-r--r--textproc/iiimf-gtk/distinfo1
-rw-r--r--textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.in22
-rw-r--r--textproc/iiimf-gtk/pkg-descr21
-rw-r--r--textproc/iiimf-gtk/pkg-plist3
5 files changed, 88 insertions, 0 deletions
diff --git a/textproc/iiimf-gtk/Makefile b/textproc/iiimf-gtk/Makefile
new file mode 100644
index 000000000000..80c6b287a95a
--- /dev/null
+++ b/textproc/iiimf-gtk/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: iiimf-gtk
+# Date created: 6 Dec 2003
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-gtk
+PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method Gtk Client Framework
+
+LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
+ iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+
+IIIMF_VER= r11_4-1467
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/iiimgcf
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
+ -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
+ -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
+ -e "s,/usr/lib/im,${LOCALBASE}/lib/im,g" \
+ -e "s,-I\$$(IM_INCLUDEDIR),-I${LOCALBASE}/include/iiimf,g" \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/iiimf-gtk/distinfo b/textproc/iiimf-gtk/distinfo
new file mode 100644
index 000000000000..4ec913af341f
--- /dev/null
+++ b/textproc/iiimf-gtk/distinfo
@@ -0,0 +1 @@
+MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
diff --git a/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.in b/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.in
new file mode 100644
index 000000000000..dd2e1e68b400
--- /dev/null
+++ b/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig Sun Dec 7 19:17:54 2003
++++ Makefile.in Sun Dec 7 19:18:40 2003
+@@ -140,8 +140,7 @@
+ imiiim.c
+
+ im_iiim_la_LIBADD = $(GTK_LIBS) \
+- $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la
++ -L$(prefix)/lib -liiimcf -liiimp
+
+
+ module_LTLIBRARIES = im-iiim.la
+@@ -152,8 +151,7 @@
+ CONFIG_CLEAN_FILES =
+ LTLIBRARIES = $(module_LTLIBRARIES)
+
+-im_iiim_la_DEPENDENCIES = $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la
++im_iiim_la_DEPENDENCIES =
+ am_im_iiim_la_OBJECTS = im_iiim_la-IIIMGdkEventKey.lo \
+ im_iiim_la-gtkimcontextiiim.lo im_iiim_la-imiiim.lo
+ im_iiim_la_OBJECTS = $(am_im_iiim_la_OBJECTS)
diff --git a/textproc/iiimf-gtk/pkg-descr b/textproc/iiimf-gtk/pkg-descr
new file mode 100644
index 000000000000..ac72b20e8941
--- /dev/null
+++ b/textproc/iiimf-gtk/pkg-descr
@@ -0,0 +1,21 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+which provides the following capabilities;
+
+* Multiplatform, platform independent.
+* Multlingual and Full UNICODE support, but satisfactory for native speakers.
+* Windowing System Independent.
+* Multiple language engines concurrently run.
+* Multiuser.
+* Distributed, lightweight clients and scalable server.
+* Extensible in multiple means.
+* Input method protocol efficient enough to be used over low-speed modem
+ connection.
+* Easy input method engine development with plugin API.
+* Easy input method enabling with libiiimcf, even on console apps.
+* Small core part to start from.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/textproc/iiimf-gtk/pkg-plist b/textproc/iiimf-gtk/pkg-plist
new file mode 100644
index 000000000000..06512cc759ad
--- /dev/null
+++ b/textproc/iiimf-gtk/pkg-plist
@@ -0,0 +1,3 @@
+lib/gtk-2.0/2.2.0/immodules/im-iiim.so
+lib/gtk-2.0/2.2.0/immodules/im-iiim.la
+lib/gtk-2.0/2.2.0/immodules/im-iiim.a