aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-x-lib/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-13 19:35:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-13 19:35:34 +0000
commit183bd15c0ec113c0015b05c0da0a613d015b1250 (patch)
tree25f2f28498df28b57749f60c6363454b1fa5fa3e /textproc/iiimf-x-lib/files
parentbd9b2225347aec0a9f522243052fc6e925afa79a (diff)
downloadports-183bd15c0ec113c0015b05c0da0a613d015b1250.tar.gz
ports-183bd15c0ec113c0015b05c0da0a613d015b1250.zip
Add iiimf-x-lib, X Client Framework for Internet/Intranet Input Method
PR: ports/72613 Submitted by: Kuang-che Wu <kcwu@csie.org>
Notes
Notes: svn path=/head/; revision=119287
Diffstat (limited to 'textproc/iiimf-x-lib/files')
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am12
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c16
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c11
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c22
4 files changed, 61 insertions, 0 deletions
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am
new file mode 100644
index 000000000000..0f410643b08e
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am
@@ -0,0 +1,12 @@
+--- iiimp/Makefile.am.orig Sun Sep 5 05:33:03 2004
++++ iiimp/Makefile.am Sun Sep 5 05:33:26 2004
+@@ -9,7 +9,7 @@
+ # -Wl,-z -Wl,defs
+ xiiimp_la_LIBADD = $(X_LIBS) \
+- $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la \
++ -L$(LOCALBASE)/lib -liiimcf \
++ -L$(LOCALBASE)/lib -liiimp \
+ $(DLOPEN_LIBS) $(THREAD_LIBS)
+ xiiimp_la_SOURCES = \
+ genutil.c \
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
new file mode 100644
index 000000000000..706ace9314bb
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
@@ -0,0 +1,16 @@
+--- iiimp/iiimpAux.c.orig Wed Oct 13 21:13:37 2004
++++ iiimp/iiimpAux.c Wed Oct 13 21:14:40 2004
+@@ -1997,11 +1997,12 @@
+ static void
+ service_set_conversion_mode(aux_t * aux, int conversion_mode)
+ {
++ XVaNestedList preedit_attr;
+ XIC xic = (XIC)aux->ic;
+ XIMPreeditState preedit_state;
+
+ preedit_state = (conversion_mode == 1 ? XIMPreeditEnable : XIMPreeditDisable);
+- XVaNestedList preedit_attr = XVaCreateNestedList(0,
++ preedit_attr = XVaCreateNestedList(0,
+ XNPreeditState, preedit_state,
+ 0);
+ XSetICValues((XIC)xic,
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c
new file mode 100644
index 000000000000..cb4570473b80
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c
@@ -0,0 +1,11 @@
+--- iiimp/iiimpConv.c.orig Tue Sep 7 20:42:04 2004
++++ iiimp/iiimpConv.c Tue Sep 7 20:42:22 2004
+@@ -44,7 +44,7 @@
+ #if defined(sun)
+ #define USE_ICONV
+ #else
+-#define USE_ICONV
++#define USE_CSCONV
+ #endif
+ #endif
+
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c
new file mode 100644
index 000000000000..26dc0f2441b0
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c
@@ -0,0 +1,22 @@
+--- iiimp/iiimpSwitcher.c.orig Thu Apr 29 23:04:48 2004
++++ iiimp/iiimpSwitcher.c Wed Oct 13 21:25:32 2004
+@@ -108,14 +108,16 @@
+ char *
+ my_stpcpy (char *dest, const char *src)
+ {
++#ifndef HAVE_STPCPY
++ register char *d = dest;
++ register const char *s = src;
++#endif
++
+ if (dest == NULL || src == NULL)
+ return NULL;
+ #ifdef HAVE_STPCPY
+ return stpcpy (dest, src);
+ #else
+- register char *d = dest;
+- register const char *s = src;
+-
+ do
+ *d++ = *s;
+ while (*s++ != '\0');