aboutsummaryrefslogtreecommitdiff
path: root/textproc/info2man/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-01-23 21:55:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-01-23 21:55:46 +0000
commit797b6b5689e0475d08f6c67bfead77f524eb57ac (patch)
tree96d141bffe589a9c3838492ca8b5f8bdeaf0c701 /textproc/info2man/Makefile
parentbf4f53c67586eb1803b33c4ff86ce5ab5162f656 (diff)
downloadports-797b6b5689e0475d08f6c67bfead77f524eb57ac.tar.gz
ports-797b6b5689e0475d08f6c67bfead77f524eb57ac.zip
Add info2man: translate GNU info files into man pages.
Notes
Notes: svn path=/head/; revision=127150
Diffstat (limited to 'textproc/info2man/Makefile')
-rw-r--r--textproc/info2man/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/info2man/Makefile b/textproc/info2man/Makefile
new file mode 100644
index 000000000000..df4d6b878fa0
--- /dev/null
+++ b/textproc/info2man/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: info2man
+# Date created: 19 January 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= info2man
+PORTVERSION= 20040717
+CATEGORIES= textproc
+MASTER_SITES= http://www.cskk.ezoshosting.com/cs/css/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Translate GNU info files into man pages
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLSCRIPTS= info2man info2pod
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/info2pod
+
+do-install:
+ ${INSTALL_SCRIPT} ${PLSCRIPTS:S|^|${WRKSRC}/|} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/cs ${DATADIR}
+
+.include <bsd.port.mk>