aboutsummaryrefslogtreecommitdiff
path: root/textproc/intltool
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-07 17:01:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-07 17:01:11 +0000
commit645a5d96ff65e2a90b6ca5712058c9baef5f28f7 (patch)
tree8c429353958b206b19d2f1798d0da1bf79309d0d /textproc/intltool
parent9a9c9f526efba1ced5f8b1734a3055d9193caa77 (diff)
downloadports-645a5d96ff65e2a90b6ca5712058c9baef5f28f7.tar.gz
ports-645a5d96ff65e2a90b6ca5712058c9baef5f28f7.zip
Resetore the OrigTree legacy cruft for ports that still need it.
Reported by: linimon
Notes
Notes: svn path=/head/; revision=186827
Diffstat (limited to 'textproc/intltool')
-rw-r--r--textproc/intltool/Makefile6
-rw-r--r--textproc/intltool/files/OrigTree.pm91
2 files changed, 97 insertions, 0 deletions
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index d44a73f3f3f0..312b01459623 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= intltool
PORTVERSION= 0.35.5
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.35
@@ -41,4 +42,9 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
-E -e '/^mkinstalldirs[[:space:]]*=/s^/\.\.^^g'
+post-install:
+ ${MKDIR} ${PREFIX}/share/intltool/XML/Parser/Style
+ ${INSTALL_DATA} ${FILESDIR}/OrigTree.pm \
+ ${PREFIX}/share/intltool/XML/Parser/Style
+
.include <bsd.port.post.mk>
diff --git a/textproc/intltool/files/OrigTree.pm b/textproc/intltool/files/OrigTree.pm
new file mode 100644
index 000000000000..020400cfa35c
--- /dev/null
+++ b/textproc/intltool/files/OrigTree.pm
@@ -0,0 +1,91 @@
+# $Id: OrigTree.pm,v 1.1 2003/11/26 15:18:28 kenneth Exp $
+
+package XML::Parser::Style::OrigTree;
+$XML::Parser::Built_In_Styles{OrigTree} = 1;
+
+sub Init {
+ my $expat = shift;
+ $expat->{Lists} = [];
+ $expat->{Curlist} = $expat->{OrigTree} = [];
+}
+
+sub Start {
+ my $expat = shift;
+ my $tag = shift;
+ my $newlist = [ { @_ } ];
+ push @{ $expat->{Lists} }, $expat->{Curlist};
+ push @{ $expat->{Curlist} }, $tag => $newlist;
+ $expat->{Curlist} = $newlist;
+}
+
+sub End {
+ my $expat = shift;
+ my $tag = shift;
+ $expat->{Curlist} = pop @{ $expat->{Lists} };
+}
+
+sub Char {
+ my $expat = shift;
+ my $text = shift;
+ my $clist = $expat->{Curlist};
+ my $pos = $#$clist;
+
+ if ($pos > 0 and $clist->[$pos - 1] eq '0') {
+ $clist->[$pos] .= $expat->original_string();
+ } else {
+ push @$clist, 0 => $expat->original_string();
+ }
+}
+
+sub Final {
+ my $expat = shift;
+ delete $expat->{Curlist};
+ delete $expat->{Lists};
+ $expat->{OrigTree};
+}
+
+1;
+__END__
+
+=head1 NAME
+
+XML::Parser::Style::OrigTree
+
+=head1 SYNOPSIS
+
+ use XML::Parser;
+ my $p = XML::Parser->new(Style => 'OrigTree');
+ my $tree = $p->parsefile('foo.xml');
+
+=head1 DESCRIPTION
+
+This module is a variant of the XML::Parser's Tree style parser. It
+uses original_string, so that Entities are not converted.
+
+When parsing a document, C<parse()> will return a parse tree for the
+document. Each node in the tree
+takes the form of a tag, content pair. Text nodes are represented with
+a pseudo-tag of "0" and the string that is their content. For elements,
+the content is an array reference. The first item in the array is a
+(possibly empty) hash reference containing attributes. The remainder of
+the array is a sequence of tag-content pairs representing the content
+of the element.
+
+So for example the result of parsing:
+
+ <foo><head id="a">Hello <em>there</em></head><bar>Howdy<ref/></bar>do</foo>
+
+would be:
+ Tag Content
+ ==================================================================
+ [foo, [{}, head, [{id => "a"}, 0, "Hello ", em, [{}, 0, "there"]],
+ bar, [ {}, 0, "Howdy", ref, [{}]],
+ 0, "do"
+ ]
+ ]
+
+The root document "foo", has 3 children: a "head" element, a "bar"
+element and the text "do". After the empty attribute hash, these are
+represented in it's contents by 3 tag-content pairs.
+
+=cut