aboutsummaryrefslogtreecommitdiff
path: root/textproc/ispell
diff options
context:
space:
mode:
authorJeroen Ruigrok van der Werven <asmodai@FreeBSD.org>2001-01-10 08:25:42 +0000
committerJeroen Ruigrok van der Werven <asmodai@FreeBSD.org>2001-01-10 08:25:42 +0000
commitf35a5725d7fac092a966b8f2407a55027fd79203 (patch)
tree6a4d04fcf881c0debb61d64718d0e178633d9f39 /textproc/ispell
parent98526b6497f01cdf45f20b4b21c9ceb6121c156e (diff)
downloadports-f35a5725d7fac092a966b8f2407a55027fd79203.tar.gz
ports-f35a5725d7fac092a966b8f2407a55027fd79203.zip
Add Danish ispell support under the variable ISPELL_DK.
This is based on the ispell-da-1.4.7 tarball.
Notes
Notes: svn path=/head/; revision=37058
Diffstat (limited to 'textproc/ispell')
-rw-r--r--textproc/ispell/Makefile21
-rw-r--r--textproc/ispell/distinfo1
-rw-r--r--textproc/ispell/files/DK.patch11
-rw-r--r--textproc/ispell/pkg-descr1
-rw-r--r--textproc/ispell/pkg-plist.dk2
5 files changed, 35 insertions, 1 deletions
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index 721159314445..52b492b2385a 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -31,7 +31,7 @@ ALL_TARGET=
BUILDHASH= ${WRKSRC}/buildhash
DATADIR= ${PREFIX}/share/ispell
-.if (!defined(ISPELL_FR) && !defined(ISPELL_SE) && !defined(ISPELL_BR) && !defined(ISPELL_DENEU) && !defined(ISPELL_DEALT) && !defined(ISPELL_BRITISH) && !defined(ISPELL_NO) && !defined(ISPELL_NL))
+.if (!defined(ISPELL_FR) && !defined(ISPELL_SE) && !defined(ISPELL_BR) && !defined(ISPELL_DENEU) && !defined(ISPELL_DEALT) && !defined(ISPELL_BRITISH) && !defined(ISPELL_NO) && !defined(ISPELL_NL) && !defined(ISPELL_DK))
pre-everything:
@${ECHO_MSG} '*********************************************************'
@${ECHO_MSG} '* You can add further dictionaries: *'
@@ -39,6 +39,7 @@ pre-everything:
@${ECHO_MSG} '* - British ISPELL_BRITISH=yes *'
@${ECHO_MSG} '* (replaces the American dictionary) *'
@${ECHO_MSG} '* - Dutch ISPELL_NL=yes *'
+ @${ECHO_MSG} '* - Danish ISPELL_DK=yes *'
@${ECHO_MSG} '* - French ISPELL_FR=yes *'
@${ECHO_MSG} '* - Brasilian ISPELL_BR=yes *'
@${ECHO_MSG} '* - German (old spelling) ISPELL_DEALT=yes *'
@@ -92,6 +93,14 @@ MASTER_SITE_SUBDIR= asmodai
EXTRA_DICT+= ${NLDISTFILE}
EXTRACT_ONLY+= ${NLDISTFILE}
.endif
+.if defined(ISPELL_DK)
+DKDISTFILE= ispell-da-1.4.7.tar.gz
+MASTER_SITES+= http://da.speling.org/filer/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= asmodai
+EXTRA_DICT+= ${DKDISTFILE}
+EXTRACT_ONLY+= ${DKDISTFILE}
+.endif
DISTFILES+= ${EXTRA_DICT}
@@ -130,6 +139,9 @@ post-patch:
.if defined(ISPELL_NL)
@cd ${WRKDIR} && ${PATCH} < ${FILESDIR}/NL.patch 2>/dev/null
.endif
+.if defined(ISPELL_DK)
+ @cd ${WRKDIR} && ${PATCH} < ${FILESDIR}/DK.patch 2>/dev/null
+.endif
post-configure:
@@ -176,6 +188,10 @@ post-build:
@cd ${WRKDIR}/${NLDISTFILE:S=.tar.gz==} && \
${MAKE} ${MAKEFLAGS} BUILDHASH=${BUILDHASH} all
.endif
+.if defined(ISPELL_DK)
+ @cd ${WRKDIR}/${DKDISTFILE:S=.tar.gz==} && \
+ ${MAKE} ${MAKEFLAGS} BUILDHASH=${BUILDHASH} all
+.endif
pre-install:
@if [ ! -d ${DATADIR} ]; then ${MKDIR} ${DATADIR}; fi
@@ -203,6 +219,9 @@ post-install:
.if defined(ISPELL_NL)
@${CAT} ${MASTERDIR}/pkg-plist.nl >> ${TMPPLIST}
.endif
+.if defined(ISPELL_DK)
+ @${CAT} ${MASTERDIR}/pkg-plist.dk >> ${TMPPLIST}
+.endif
.if defined(ISPELL_BRITISH)
@${CAT} ${MASTERDIR}/pkg-plist.british >> ${TMPPLIST}
.else
diff --git a/textproc/ispell/distinfo b/textproc/ispell/distinfo
index 6abe6d82d910..1a42d0eab3d7 100644
--- a/textproc/ispell/distinfo
+++ b/textproc/ispell/distinfo
@@ -7,3 +7,4 @@ MD5 (ispell-html-mode.patch) = 1b44441a3748e55b3d509fcff21af4b7
MD5 (br.ispell-2.4.tar.gz) = 241d9e2fefb92ea74f13c1e07d0b4e7b
MD5 (ispell-norsk-1.1a.tar.gz) = d096dce5003b4e221e96fbf34f523c4c
MD5 (ispell-nl-1.0.0.tar.gz) = d9f8c68f28053e71792053e34201a28b
+MD5 (ispell-da-1.4.7.tar.gz) = 767ee1ce66b1213c45b086b59bf44312
diff --git a/textproc/ispell/files/DK.patch b/textproc/ispell/files/DK.patch
new file mode 100644
index 000000000000..a309dc24a1d7
--- /dev/null
+++ b/textproc/ispell/files/DK.patch
@@ -0,0 +1,11 @@
+--- ispell-da-1.4.7/Makefile.orig Tue Jan 2 10:47:45 2001
++++ ispell-da-1.4.7/Makefile Wed Jan 10 09:10:51 2001
+@@ -7,7 +7,7 @@
+ install -o root -g root -m 0644 dansk.aff $(installdir)
+
+ dansk.hash: dansk.aff words-da.ispell
+- buildhash words-da.ispell dansk.aff dansk.hash
++ ${BUILDHASH} words-da.ispell dansk.aff dansk.hash
+
+ clean:
+ rm -f words-da.ispell.stat dansk.hash words-da.ispell.cnt *~
diff --git a/textproc/ispell/pkg-descr b/textproc/ispell/pkg-descr
index 965039080507..d3eec1f230ce 100644
--- a/textproc/ispell/pkg-descr
+++ b/textproc/ispell/pkg-descr
@@ -5,6 +5,7 @@ is faster and much easier to use. Ispell can also handle languages
other than English.
Included in this port are:
- British English
+ - Danish
- Dutch
- French
- Brasilian
diff --git a/textproc/ispell/pkg-plist.dk b/textproc/ispell/pkg-plist.dk
new file mode 100644
index 000000000000..a6f64643e810
--- /dev/null
+++ b/textproc/ispell/pkg-plist.dk
@@ -0,0 +1,2 @@
+share/ispell/dansk.aff
+share/ispell/dansk.hash