aboutsummaryrefslogtreecommitdiff
path: root/textproc/latex2html
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:21:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:21:41 +0000
commit181f872139dc1f6dcee72930510a791e608d150e (patch)
tree9c2eb300193d09ba7f86bdd1e257d3963a2a2921 /textproc/latex2html
parent49482ce38463823b1a78ded911d3f5b64b823604 (diff)
downloadports-181f872139dc1f6dcee72930510a791e608d150e.tar.gz
ports-181f872139dc1f6dcee72930510a791e608d150e.zip
[PATCH] textproc/latex2html: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54951 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88146
Diffstat (limited to 'textproc/latex2html')
-rw-r--r--textproc/latex2html/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/textproc/latex2html/Makefile b/textproc/latex2html/Makefile
index bcfe8a7b84db..accaa4536abc 100644
--- a/textproc/latex2html/Makefile
+++ b/textproc/latex2html/Makefile
@@ -21,8 +21,14 @@ COMMENT= Convert LaTeX documents to HTML
# Global variables
#
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
BUILD_DEPENDS= ${LOCALBASE}/bin/latex:${PORTSDIR}/print/teTeX \
- ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu \
+ ${LOCALBASE}/bin/gs:${PORTSDIR}/${GSPORT} \
${LOCALBASE}/bin/anytopnm:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -42,6 +48,17 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
DOC_FILES= FAQ INSTALL LICENSE README
+# Inform message
+#
+
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
# Port-patch
#