aboutsummaryrefslogtreecommitdiff
path: root/textproc/liblrdf
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-27 14:27:54 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-27 14:27:54 +0000
commit843926595caf5f3c39aa6035ea1b6389652d7ffb (patch)
tree8996963c071bc951719a10538badb6ac030c3ad1 /textproc/liblrdf
parent353f2c7af838bc88636ddd9fcb3ef46610e202ba (diff)
downloadports-843926595caf5f3c39aa6035ea1b6389652d7ffb.tar.gz
ports-843926595caf5f3c39aa6035ea1b6389652d7ffb.zip
Add liblrdf, a library for manipulating RDF files describing LADSPA plugins.
Notes
Notes: svn path=/head/; revision=79739
Diffstat (limited to 'textproc/liblrdf')
-rw-r--r--textproc/liblrdf/Makefile30
-rw-r--r--textproc/liblrdf/distinfo1
-rw-r--r--textproc/liblrdf/pkg-descr10
-rw-r--r--textproc/liblrdf/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/liblrdf/Makefile b/textproc/liblrdf/Makefile
new file mode 100644
index 000000000000..19f2e23731c0
--- /dev/null
+++ b/textproc/liblrdf/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: liblrdf
+# Date created: 26 April 2003
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= liblrdf
+PORTVERSION= 0.3.0
+CATEGORIES= textproc
+MASTER_SITES= http://plugin.org.uk/releases/lrdf/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Library for manipulating RDF files describing LADSPA plugins
+
+LIB_DEPENDS= raptor.0:${PORTSDIR}/textproc/raptor
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehack
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,1:2:2,1:2:1,' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/liblrdf/distinfo b/textproc/liblrdf/distinfo
new file mode 100644
index 000000000000..82681207dc85
--- /dev/null
+++ b/textproc/liblrdf/distinfo
@@ -0,0 +1 @@
+MD5 (liblrdf-0.3.0.tar.gz) = a8622b3c28429d64d761d18b82d7e2c8
diff --git a/textproc/liblrdf/pkg-descr b/textproc/liblrdf/pkg-descr
new file mode 100644
index 000000000000..695a21f864ee
--- /dev/null
+++ b/textproc/liblrdf/pkg-descr
@@ -0,0 +1,10 @@
+This is a library to make it easy to manipulate RDF files describing LADSPA
+plugins.
+
+It can also be used for general RDF manipulation.
+
+It can read RDF/XLM and N3 files and export N3 files, it also has a light
+taxonomic inference capablility.
+
+Author: Steve Harris <steve@plugin.org.uk>
+WWW: http://www.plugin.org.uk/
diff --git a/textproc/liblrdf/pkg-plist b/textproc/liblrdf/pkg-plist
new file mode 100644
index 000000000000..583b46092044
--- /dev/null
+++ b/textproc/liblrdf/pkg-plist
@@ -0,0 +1,9 @@
+include/lrdf.h
+include/lrdf_types.h
+lib/liblrdf.a
+lib/liblrdf.so
+lib/liblrdf.so.1
+share/ladspa/rdf/ladspa.rdfs
+libdata/pkgconfig/lrdf.pc
+@dirrm share/ladspa/rdf
+@unexec rmdir %D/share/ladspa 2>/dev/null || true