aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2012-03-16 02:27:04 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2012-03-16 02:27:04 +0000
commit4a44abaad9e566d3de70ded96f238dd80fd3d9f1 (patch)
tree3e8a6b426ad7321e94fc3b067bc71a6f7e15223d /textproc/libxml2/Makefile
parentd8911fc5686e3a1bfe569e77f6a0ee9c0d77abbd (diff)
downloadports-4a44abaad9e566d3de70ded96f238dd80fd3d9f1.tar.gz
ports-4a44abaad9e566d3de70ded96f238dd80fd3d9f1.zip
-Make the iconv optional.
PR: ports/162571 Submitted by: Pedro Giffuni <giffunip@tutopia.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=293390
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index e4262bc5d65b..dc747bb953ce 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -28,17 +28,20 @@ COMMENT?= XML parser library for GNOME
USE_CSTD= gnu89
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomehack pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
- --with-html-dir=${PREFIX}/share/doc \
+CONFIGURE_ARGS?=---with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--without-python
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.if !defined(WITHOUT_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+.endif
+
.if !defined(MASTERDIR)
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3