aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-11-02 22:49:26 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-11-02 22:49:26 +0000
commitba7ff2952cce369b87eae07d1be57e4c63f1645b (patch)
treed144d3ea676d1c96ab2f9a3b294fd4d0eb557c9d /textproc/libxml2/Makefile
parent0c416192b4b01b68dceaa46aee7f39a1806d9c3a (diff)
downloadports-ba7ff2952cce369b87eae07d1be57e4c63f1645b.tar.gz
ports-ba7ff2952cce369b87eae07d1be57e4c63f1645b.zip
Do the WITH_FBSD10_FIX manualy, because it doesn't do the right thing (yet).
This should unbreak the python bindings. Reported by: miwi and pointyhat (via pav)
Notes
Notes: svn path=/head/; revision=284939
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 31c113df02f7..ae151bd6d170 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -32,7 +32,7 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomehack pkgconfig
USE_LDCONFIG= yes
-WITH_FBSD10_FIX=yes
+#WITH_FBSD10_FIX=yes
CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
@@ -75,10 +75,13 @@ post-patch:
's|/etc/xml/catalog|${LOCALBASE}/share/xml/catalog|g; \
s|/etc/sgml/catalog|${LOCALBASE}/share/sgml/catalog|g' ${WRKSRC}/${f}
.endfor
-
-pre-build:
- @${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
- ${WRKSRC}/configure ${WRKSRC}/config.h.in
+# manual patch because WITH_FBSD10_FIX break the python bindings
+ ${FIND} ${WRKSRC} -type f -name configure \
+ -exec ${SH} -c " \
+ mtime=\$$(date -r \$$(stat -f '%m' \$$0) '+%Y%m%d%H%M.%S'); \
+ ${SED} -i '.batman' -e 's|freebsd1\*)|freebsd1.\*)|g' \
+ -e 's|freebsd\[123\]\*)|freebsd[123].*)|g' \$$0; \
+ touch -mt \$$mtime \$$0" {} \; || /usr/bin/true
.include <bsd.port.mk>