aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-24 20:19:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-24 20:19:08 +0000
commit39212fa861f2b219981000dd008093f4f8a3d1b3 (patch)
tree75523cc2aaaeecb00ac186868b00ec79b7be29b8 /textproc/libxml2
parent2d8dec928f8aae48d899442c346c9717efc38daa (diff)
downloadports-39212fa861f2b219981000dd008093f4f8a3d1b3.tar.gz
ports-39212fa861f2b219981000dd008093f4f8a3d1b3.zip
- Change tunables from OPTIONS to plain make defines. Too many users
subconsciously enabled THREADS knob and ended with breakages later. The last straw: Adam McLaurin <adam.mclaurin@gmx.net> Approved by: FreeBSD/GNOME cabal
Notes
Notes: svn path=/head/; revision=122335
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 2e7989834613..0b428b06ca62 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -4,6 +4,12 @@
#
# $FreeBSD$
#
+# WITH_THREADS enable pthread support (WILL BREAK OTHER PORTS!)
+# WITHOUT_SCHEMA disable XML schema support
+# WITH_MEM_DEBUG enable memory debugging (DEVELOPERS ONLY!)
+# WITH_XMLLINT_HIST enable history for xmllint
+# WITH_THREAD_ALLOC enable per-thread memory (DEVELOPERS ONLY!)
+#
PORTNAME= libxml2
PORTVERSION= 2.6.16
@@ -32,16 +38,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if !defined(MASTERDIR)
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3
-
-OPTIONS= THREADS "Enable pthread support (MAY BREAK OTHER PORTS!)" off \
- SCHEMA "Enable XML schema support" on \
- MEM_DEBUG "Enable memory debugging (DEVELOPERS ONLY!)" off \
- XMLLINT_HIST "Enable history for xmllint" off \
- THREAD_ALLOC "Enable per-thread memory (DEVELOPERS ONLY!)" off
.endif
-.include <bsd.port.pre.mk>
-
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
.else
@@ -68,4 +66,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/catalog.c ${WRKSRC}/xmlcatalog.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>