aboutsummaryrefslogtreecommitdiff
path: root/textproc/lttoolbox
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:47:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:47:02 +0000
commitc7e0c5c34c60044d029b4729edd9edba760080eb (patch)
tree9a09b76f0be6bbace36dcae67faf23fe1eaa2594 /textproc/lttoolbox
parentff7976e8ce8797bb8a53e914e8d62ae575a534a3 (diff)
downloadports-c7e0c5c34c60044d029b4729edd9edba760080eb.tar.gz
ports-c7e0c5c34c60044d029b4729edd9edba760080eb.zip
lttoolbox is a toolbox for lexical processing, morphological analysis
and generation of words. The analysis is the process of splitting of words splitting a word (e.g. cats) into its lemma 'cat' and the grammatical information <n><pl>. The generation is the opposite process. The package is split into three programs, lt-comp, the compiler, lt-proc, the processor, and lt-expand, which generates all possible mappings between surface forms and lexical forms in the dictionary. WWW: http://wiki.apertium.org/wiki/Lttoolbox PR: ports/137134 Submitted by: Mykola Dzham <freebsd at levsha.org.ua>
Notes
Notes: svn path=/head/; revision=238542
Diffstat (limited to 'textproc/lttoolbox')
-rw-r--r--textproc/lttoolbox/Makefile25
-rw-r--r--textproc/lttoolbox/distinfo3
-rw-r--r--textproc/lttoolbox/pkg-descr10
-rw-r--r--textproc/lttoolbox/pkg-plist39
4 files changed, 77 insertions, 0 deletions
diff --git a/textproc/lttoolbox/Makefile b/textproc/lttoolbox/Makefile
new file mode 100644
index 000000000000..695485d1505f
--- /dev/null
+++ b/textproc/lttoolbox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: lttoolbox
+# Date created: 14 April 2009
+# Whom: Mykola Dzham <freebsd@levsha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lttoolbox
+PORTVERSION= 3.1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/apertium
+
+MAINTAINER= freebsd@levsha.org.ua
+COMMENT= A tool for lexical, morphological analysis and generation of words
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pkgconfig
+
+MAN1= lt-comp.1 lt-expand.1 lt-proc.1 lt-tmxcomp.1 lt-tmxproc.1
+
+.include <bsd.port.mk>
diff --git a/textproc/lttoolbox/distinfo b/textproc/lttoolbox/distinfo
new file mode 100644
index 000000000000..18aecf7bf448
--- /dev/null
+++ b/textproc/lttoolbox/distinfo
@@ -0,0 +1,3 @@
+MD5 (lttoolbox-3.1.1.tar.gz) = 52c3c4da0701e1aaaaa396fc07009d8f
+SHA256 (lttoolbox-3.1.1.tar.gz) = 27c2bf1dc69a1edf413076d0fc1330e0879504d444485dcc2a631a8ef2f91249
+SIZE (lttoolbox-3.1.1.tar.gz) = 382839
diff --git a/textproc/lttoolbox/pkg-descr b/textproc/lttoolbox/pkg-descr
new file mode 100644
index 000000000000..83c003146c77
--- /dev/null
+++ b/textproc/lttoolbox/pkg-descr
@@ -0,0 +1,10 @@
+lttoolbox is a toolbox for lexical processing, morphological analysis
+and generation of words. The analysis is the process of splitting of
+words splitting a word (e.g. cats) into its lemma 'cat' and the
+grammatical information <n><pl>. The generation is the opposite
+process.
+The package is split into three programs, lt-comp, the compiler,
+lt-proc, the processor, and lt-expand, which generates all possible
+mappings between surface forms and lexical forms in the dictionary.
+
+WWW: http://wiki.apertium.org/wiki/Lttoolbox
diff --git a/textproc/lttoolbox/pkg-plist b/textproc/lttoolbox/pkg-plist
new file mode 100644
index 000000000000..01e82f025cb2
--- /dev/null
+++ b/textproc/lttoolbox/pkg-plist
@@ -0,0 +1,39 @@
+bin/lt-comp
+bin/lt-expand
+bin/lt-proc
+bin/lt-tmxcomp
+bin/lt-tmxproc
+include/lttoolbox-3.1/lttoolbox/alphabet.h
+include/lttoolbox-3.1/lttoolbox/buffer.h
+include/lttoolbox-3.1/lttoolbox/compiler.h
+include/lttoolbox-3.1/lttoolbox/compression.h
+include/lttoolbox-3.1/lttoolbox/entry_token.h
+include/lttoolbox-3.1/lttoolbox/exception.h
+include/lttoolbox-3.1/lttoolbox/expander.h
+include/lttoolbox-3.1/lttoolbox/fst_processor.h
+include/lttoolbox-3.1/lttoolbox/lt_locale.h
+include/lttoolbox-3.1/lttoolbox/ltstr.h
+include/lttoolbox-3.1/lttoolbox/match_exe.h
+include/lttoolbox-3.1/lttoolbox/match_node.h
+include/lttoolbox-3.1/lttoolbox/match_state.h
+include/lttoolbox-3.1/lttoolbox/my_stdio.h
+include/lttoolbox-3.1/lttoolbox/node.h
+include/lttoolbox-3.1/lttoolbox/pattern_list.h
+include/lttoolbox-3.1/lttoolbox/pool.h
+include/lttoolbox-3.1/lttoolbox/regexp_compiler.h
+include/lttoolbox-3.1/lttoolbox/sorted_vector.h
+include/lttoolbox-3.1/lttoolbox/state.h
+include/lttoolbox-3.1/lttoolbox/tmx_compiler.h
+include/lttoolbox-3.1/lttoolbox/trans_exe.h
+include/lttoolbox-3.1/lttoolbox/transducer.h
+include/lttoolbox-3.1/lttoolbox/xml_parse_util.h
+lib/liblttoolbox3-3.1.so
+lib/liblttoolbox3-3.1.so.0
+lib/liblttoolbox3.a
+lib/liblttoolbox3.la
+lib/liblttoolbox3.so
+libdata/pkgconfig/lttoolbox-3.1.pc
+%%DATADIR%%/dix.dtd
+@dirrm %%DATADIR%%
+@dirrm include/lttoolbox-3.1/lttoolbox
+@dirrm include/lttoolbox-3.1